lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 06-29-2009, 08:45 AM   #1
Not Yet Wild
 
Join Date: Jul 2008
Posts: 5
Default 04 precedent "jumping" after alltrax upgrade

I installed a 500 amp alltrax controler in my 04 precendent (no lift kit, standard tires) after installing a plum quick motor. I was tring to get more low end torque. Now after trying to adjust the programming and even a a custom throttle response it jumps real bad on starting. There is no way to make a smooth take off. I have decided to reinstall the orginal curtis controler to see if it is the speed controler, if not maybe the mcor, however I have lost the paper that had the orginal wiring for the curtis controler. Does anyone have one or any other ideas?
onewoody1 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 06-29-2009, 08:49 AM   #2
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,082
Default Re: 04 precedent "jumping" after alltrax upgrade

Have you tested the MCOR output with an ohms meter? Maybe it is not putting out a smooth 5k-0? What setting did you put the throttle response at ?
scottyb is online now   Reply With Quote
Unread 06-29-2009, 08:57 AM   #3
Not Yet Wild
 
Join Date: Jul 2008
Posts: 5
Default Re: 04 precedent "jumping" after alltrax upgrade

I have tried numerouse throttle settings, and the lower ones it is not quite as bad, it is presently set on three. This is my first cart so be gently with me, where would I hook up th ohm meter?
onewoody1 is offline   Reply With Quote
Unread 06-29-2009, 09:13 AM   #4
Getting Wild
 
butterface's Avatar
Club Car
 
Join Date: Jan 2009
Location: Oxford, FL
Posts: 123
Default Re: 04 precedent "jumping" after alltrax upgrade

Read the thread below. I know it is not on a precedent and the wiring will be a little different, but the response you are getting sounds the same.

99 DS Has full throttle only
butterface is offline   Reply With Quote
Unread 06-29-2009, 09:23 AM   #5
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,082
Default Re: 04 precedent "jumping" after alltrax upgrade

There are 3 small wires connected to the controller one (maybe blue) and a black and white wire. THe color wire is the power for the controller 48v. And the black and white is the throttle indicator (MCOR) Hang on a minute, I will post the MCOR test values..... Okay here is the test process from the CC service manual in this thread..... click on the link below

How to test MCOR on 04 IQ regen cart
scottyb is online now   Reply With Quote
Unread 06-29-2009, 09:25 AM   #6
Not Yet Wild
 
Join Date: Jul 2008
Posts: 5
Default Re: 04 precedent "jumping" after alltrax upgrade

Thanks a lot, It makes sense to check that out after all what goes in comes out. I 'll let you know how it turns out. I am in cronstruction as well although not retired but may soon be but not by choice!
onewoody1 is offline   Reply With Quote
Unread 06-29-2009, 09:27 AM   #7
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,082
Default Re: 04 precedent "jumping" after alltrax upgrade

Amen to that! Good luck, let us know what you find?
scottyb is online now   Reply With Quote
Unread 06-29-2009, 08:09 PM   #8
Not Yet Wild
 
Join Date: Jul 2008
Posts: 5
Default Re: 04 precedent "jumping" after alltrax upgrade

Well it has been a interesting afternoon. I put the ohm meter on the the mcor, it preformed fine, well with in limits, the same can not be said of alltrax customer support. Short story I put the old controller back in ( I am playing golf tommorrow and just couldn't wait any longer) and it worked perfectly. Smooth take off no jumping no problems. Of course it does not have the take off of the alltrax but it won't snap your neck either. Dealing with customer service at alltrax was not nearly what it claimed to be but they couldn't get back to me with the monitor data I sent e-mail to them (the service tech obiviously had no idea what he was looking at) but they promised me to e-mail me something tommorrow, lets see what they come up with. It was a very high priced controller not to work properly but I will give them the benefit of the doubt and give them a opportunity to make things right, lets hope they do the right thing!
onewoody1 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
"slow" Precedent "need Speed" Gas Club Car
Wheels and Tires in So Cal 22" paddles on Douglas, 25" Dunlop on ITP, 27" ITP's Golf Carts and Parts
What Next "Speed" Step for my Precedent Electric Club Car
2005 Precedent IR - Who Knows What "IR" Means or Stands For...? Electric Club Car


All times are GMT -5. The time now is 10:52 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.