lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 07-05-2009, 10:19 AM   #1
Not Yet Wild
Club Car
 
Join Date: Jul 2009
Location: West Harrison Indiana
Posts: 32
Default Sparks and Smoke

I have 93 DS Electric cart and now the motor was shooting sparks from it last night. I checked it today and where the throttle lever goes into a device with a bunch of wires (sorry I am new to this) I believe it is the VGlide but I am not sure. I press the throttle slowly and sparks and smoke come from it now and I can hear the motor popping. The throttle feels harder to push like it's rubbing something as it passes in the VGlide??, it was not like that before. I checked all the wires on the batteries and motor and they are all tight Any ideas???
bdw72 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 07-05-2009, 10:31 AM   #2
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,069
Default Re: Sparks and Smoke

Stop running this cart until you find the problem. Open the v-glide and inspect the contacts. I suspect it needs a rebuild. Check the motor for unwanted contiuity between and of the armature and field connections.
scottyb is online now   Reply With Quote
Unread 07-06-2009, 07:27 AM   #3
Not Yet Wild
Club Car
 
Join Date: Jul 2009
Location: West Harrison Indiana
Posts: 32
Default Re: Sparks and Smoke

OK, I looked at the contacts on the VGlide and a couple of them have little bumps or balls of copper on them. Where can order new contacts? Is it best to replace them all at the same time? I have not had a chance to test the continuity yet. Thanks!!!
bdw72 is offline   Reply With Quote
Unread 07-07-2009, 08:56 AM   #4
Not Yet Wild
Club Car
 
Join Date: Jul 2009
Location: West Harrison Indiana
Posts: 32
Default Re: Sparks and Smoke

I ordered a new V-Glide switch case and wiper brush.
bdw72 is offline   Reply With Quote
Unread 07-09-2009, 04:55 PM   #5
Not Yet Wild
Club Car
 
Join Date: Jul 2009
Location: West Harrison Indiana
Posts: 32
Default Re: Sparks and Smoke

I replaced the V-Glide and wiper and the sparks still shoot from V-Glide but only if i push the throttle half way, if i give it full throttle no sparks. It seems that the first contact has an issue once the wiper arm passes it no more sparks. The first contact was fried on the old V-Glide as well. Any Ideas????
bdw72 is offline   Reply With Quote
Unread 07-09-2009, 06:22 PM   #6
Gone Wild
 
buckmanmike's Avatar
 
Join Date: Oct 2007
Location: Snellville, Ga.
Posts: 1,062
Default Re: Sparks and Smoke

Wish I could help bdw72. I had a similar problem with an old ezgo and eventually swapped to pb-6 and controller.
buckmanmike is offline   Reply With Quote
Unread 07-10-2009, 11:00 AM   #7
Not Yet Wild
Club Car
 
Join Date: Jul 2009
Location: West Harrison Indiana
Posts: 32
Question Re: Sparks and Smoke

What would happen if i take the wire off of the bad contact, basically it looks like the wire goes to the first resistor? This thing is really frustrating.
bdw72 is offline   Reply With Quote
Unread 07-10-2009, 03:42 PM   #8
Getting Wild
 
butterface's Avatar
Club Car
 
Join Date: Jan 2009
Location: Oxford, FL
Posts: 123
Default Re: Sparks and Smoke

if you remove the wire you won't have the slow speed of the contact. i would recommend that you disconnect the batteries and try take a good look at the wiper arm moving over the contact. The problem could be the gap between the wiper arm and the contact pad (too much gap possibly). Make sure the arm has a flush contact all the way across the assembly.

Last edited by butterface; 07-10-2009 at 03:43 PM.. Reason: more information
butterface is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
voltage reducer & sparks Electric Club Car
Arcs and Sparks Electric EZGO
Newbie Here: Wires Melting, Sparks - Cart is Dead - Need Help Electric EZGO
Hot Cables and Sparks while Charging Electric Club Car
White Smoke Gas Club Car


All times are GMT -5. The time now is 12:12 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.