lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 07-06-2009, 07:28 AM   #1
Not Yet Wild
Club Car
 
Join Date: Jul 2009
Location: NC
Posts: 1
Question Lost power

I have lost power on my 1996 club car. It has new batteries and I know that isn't the problem. I was riding it and it suddenly died. I do not hear any clicking when I step on accelerator in F or R
brogers is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 07-06-2009, 09:54 AM   #2
Gone Wild
 
OLD MEC's Avatar
Club Car
 
Join Date: Mar 2009
Location: South Texas
Posts: 2,391
Default Re: Lost power

Check solenoid for power, sounds like its not closing and or you have a bad battery connection somewhere? To test solenoid jack back wheels off ground and (support solidly) and block front wheels so there can be NO MOVEMENT and then with a heavy cable jump across (two large terminals on solenoid) and see if motor runs. WARNING DO NOT ALLOW MOTOR TO RUN MORE THAN A FEW SECONDS as you can destroy a motor by over speed. If not then you have other problems to look for. it will be a case of elimination from there on to find problem.
OLD MEC is offline   Reply With Quote
Unread 10-29-2009, 07:30 PM   #3
Not Yet Wild
Club Car
 
Join Date: Sep 2009
Location: Florence, S.C.
Posts: 25
Default Re: Lost power

It could be the controler. I hope not though! One of my carts at the beach did the same thing. Seed controler had died.
Mitchell Sansbury is offline   Reply With Quote
Unread 10-30-2009, 07:24 PM   #4
just leave me alone
 
GLEEMO's Avatar
Club Car
 
Join Date: Aug 2008
Location: Tennessee
Posts: 5,643
Default Re: Lost power

Quote:
Originally Posted by brogers View Post
I have lost power on my 1996 club car. It has new batteries and I know that isn't the problem. I was riding it and it suddenly died. I do not hear any clicking when I step on accelerator in F or R
Welcome to BGW !!!

Where in NC ?
GLEEMO is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
helpppp lost power backfired and now its not turning over Gas Yamaha
upgrading wiring-lost power Electric EZGO
Lost Gas EZGO
Club car lost power on impact to differential Electric Club Car


All times are GMT -5. The time now is 12:21 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.