lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 07-10-2009, 02:04 PM   #1
mOB
Not Yet Wild
 
Join Date: Jul 2009
Posts: 4
Default electric club car ds, 1984+/-, suddenly won't run

Hi everyone, I bought a used cart to use at my house in Mexico, can't remember the exact year but early 1980's. Before trailering it down there I had it gone over by a Marine/Auto electric guy (friend) who replaced all batteries, ignition switch and went through the wireing. It ran fine before and one time after towing it to MX, next day it drove about 50 ft and stopped! Since then, it has moved a few feet in foward and reverse intermittantly and will occationally "lurch" but 99% of the time it doesn't move. I thought maybe something shook loose during transit. The batteries are fully charged, using a volt meter I seem to get power to the solenoid and controller, I've gone over all connections and they seem OK. I hear a click in back when pushing the accelerator pedal.
The problem is it's still in MX, so it may be a while before I can find someone who can work on it. Can you help me with troubleshooting? If it sounds like a solenoid I don't mind just buying one before my next trip ($30). Could it be the controller $$ or motor$$?
Thanks for your thoughts.
mOB is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 07-10-2009, 03:29 PM   #2
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,077
Default Re: electric club car ds, 1984+/-, suddenly won't run

THey didn't use controllers until early 90s..... We can't guess what it might be until we know what speed control system you have..... so we need to know the serial # or the type of system you have.... Sorry
scottyb is online now   Reply With Quote
Unread 07-10-2009, 04:49 PM   #3
mOB
Not Yet Wild
 
Join Date: Jul 2009
Posts: 4
Default Re: electric club car ds, 1984+/-, suddenly won't run

Ok, thanks, next time I'm done there (within the next month probably) I'll write down the serial number. I had looked on a couple of parts websites and it does have something that looks like the controllers in the pictures, 3x5in silver box. It's more likely that I have remembered the date/model wrong, I did figure out the year/model at some point but didn't write it down. I'm not in a great hurry so I'll get the right info and write again. Any other suggestions for now? After reading over other posting, I will go over the connections again.
I really appreciate any help!
Thanks.
mOB is offline   Reply With Quote
Unread 07-10-2009, 05:49 PM   #4
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,077
Default Re: electric club car ds, 1984+/-, suddenly won't run

Your description of a little silver box with a red end cap under the drivers seat, is consistant with the 5 solenoid carts of that era. Most likely that is what you have... You will need to read up on any "5 solenoid" threads you can find to familiarize yourself with what the system consists fo and how it works if you intend to try to fix it yourself.... There is no silver bullet the same system was used until 1988, good luck
scottyb is online now   Reply With Quote
Unread 07-10-2009, 07:48 PM   #5
mOB
Not Yet Wild
 
Join Date: Jul 2009
Posts: 4
Default Re: electric club car ds, 1984+/-, suddenly won't run

No, you were right the first time, I got the year confused, I have a wiring diagram also that shows something labeled as a controller (whatever that does) and it looks exactly like what is on mine. What I'm talking about is mounted under the deck between the front and back seat, had a black end with at least 5 flat male connectors. It also looks exactly like the one I've seen on a different site for sale.
I'll get more accurate info and let you know. The intermittant surges and lurging sounds to me like a loose wire, especially following a long road trip on a trailer. I'll recheck all the wiring again, you never know.
Thanks again.
mOB is offline   Reply With Quote
Unread 07-11-2009, 11:27 AM   #6
Not Yet Wild
Club Car
 
Join Date: Jan 2009
Location: Southeast Texas
Posts: 25
Default Re: electric club car ds, 1984+/-, suddenly won't run

I've just bought an older cc 1981 and it had the same problem. It turned out to be stuck brushes in the motor and the armature was worn.
Phil H is offline   Reply With Quote
Unread 07-12-2009, 07:22 PM   #7
mOB
Not Yet Wild
 
Join Date: Jul 2009
Posts: 4
Talking Re: electric club car ds, 1984+/-, suddenly won't run

So, did you have to replace the motor or is that repairable? Thanks. How did you figure it out by the way?
mOB is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
1984 Club Car Electric Problems Electric Club Car
1984 electric club car Electric Club Car
1984 electric club car Electric Club Car
1984 club car Electric Club Car
1995 EZGO electric suddenly won't budge Electric EZGO


All times are GMT -5. The time now is 11:43 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.