lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 07-19-2009, 10:50 AM   #21
just leave me alone
 
GLEEMO's Avatar
Club Car
 
Join Date: Aug 2008
Location: Tennessee
Posts: 5,643
Default Re: Another Not running right problem

Replace/Repair the F/R switch first , then try charging again !
These OBC may be OK after all , and the FR cable is causing it to get a bad reading
back to the charger !
GLEEMO is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 07-22-2009, 04:04 PM   #22
Not Yet Wild
Club Car
 
Join Date: Jul 2009
Location: NW OH
Posts: 22
Default Re: Another Not running right problem

Got it to charge now just waiting on a new f/r switch
radicalr1 is offline   Reply With Quote
Unread 07-23-2009, 10:38 AM   #23
just leave me alone
 
GLEEMO's Avatar
Club Car
 
Join Date: Aug 2008
Location: Tennessee
Posts: 5,643
Default Re: Another Not running right problem

So what finally fixed the charger problem ?????
GLEEMO is offline   Reply With Quote
Unread 07-23-2009, 12:28 PM   #24
Not Yet Wild
Club Car
 
Join Date: Jul 2009
Location: NW OH
Posts: 22
Default Re: Another Not running right problem

Well after chasin wires and all that fun stuff i found a bare wire to the charger port so thats fixed and i put a HD f/r switch in today now it seems to be all good THANK YOU everyone that helped me figure this stuff out I really appreciate it.. Mike
radicalr1 is offline   Reply With Quote
Unread 07-24-2009, 10:42 AM   #25
just leave me alone
 
GLEEMO's Avatar
Club Car
 
Join Date: Aug 2008
Location: Tennessee
Posts: 5,643
Default Re: Another Not running right problem

Hey Ur an expert now on OBC testing and F/R switches ,
Pay it forward
GLEEMO is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
won't stay running Gas EZGO
95 CC Running Slow Electric Club Car
Engine tries to keep running Gas Club Car
Back together and running with a new problem! Gas Yamaha
1985 g1 running problem Gas Yamaha


All times are GMT -5. The time now is 02:29 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.