lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 07-16-2009, 11:34 AM   #1
Not Yet Wild
 
Join Date: Jul 2009
Posts: 7
Exclamation golf cart regen 1 1997 need help please

Not Yet Wild


Join Date: Jul 2009
Posts: 2 97 regen1 club car need help please <<<

--------------------------------------------------------------------------------

hello guys im new to this site , i will appreciate if any one can help me i will be greatful my dad have a club car its a regen 1 it have kinda of 2 little problems..... i would like to fix it for him he is a senior citizen guy .... well the first problem is , some times the golf cart wont move on forward or reverse..... its like its dead , but when u put the charger on it for 5 min. it will run but batteryies all charged up.......it seems like when u put it on charge for 5 mins it will wake up spme thing and make it works and drivable??? the second it is i put a high speed motor in it ... it runs great with the motor but out of the hole it is very slow until it pick up speed , and the reverse its bearly moving to reverse now very very slow in reverse does any one knows why the car is acting like that.......please help thanks i would like to know why is the coil for behind the battery for???? it have the green wire hooked up to it , someone said it is different kind of speed true can u do any thing with that coil thanks again any feed back
hanivw is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 07-16-2009, 01:32 PM   #2
Not Yet Wild
 
YamahaG22GW's Avatar
Yamaha
 
Join Date: Jan 2009
Location: Ont. Canada
Posts: 14
Default Re: golf cart regen 1 1997 need help please

Most likely it is the solenoid for the electric motor. make sure your connections are clean and tight on all motor and solenoid terminals. If you don't get an answer on what it is for sure try posting some pictures maybe somebody will recognize it for you or look for a wiring diagram online. What kind of motor did you put in and was it matched with your controller? Is it possible that your batteries are not very strong? High speed motors and other mods require more juice to run properly and settings with controller will help the reverse issue but the slow to top speed is sometimes the sacrifice you make when going with some high speed motors as you often loose the torque that gets you up to top speed quickly. Again it depends on the controller you are using and its settings.

Last edited by YamahaG22GW; 07-16-2009 at 01:39 PM.. Reason: addition
YamahaG22GW is offline   Reply With Quote
Unread 07-16-2009, 01:50 PM   #3
Gone Wild
 
Fishing Dude's Avatar
Club Car
 
Join Date: Jul 2008
Location: Slums of Lake Erie
Posts: 3,722
Default Re: golf cart regen 1 1997 need help please

Is this a regen cart?
Fishing Dude is offline   Reply With Quote
Unread 07-16-2009, 02:01 PM   #4
nimda
Club Car
 
Join Date: Jun 2007
Posts: 12,912
Default Re: golf cart regen 1 1997 need help please

Sounds like part of the problem is you put a high speed motor on it without taking anything else into consideration. You can't just slap a high speed motor on there and expect the stock controller to "make it work"...just not gonna happen. You loose all your low end torque without adding a hgher amp controller.

The reverse issue, well...it could be as simple as Club Car has Half Speed reverse and with the addition of the high speed motor the controller can't produce enough amps to get it going very good.

Wires getting hot.....thats NEVER a good sign. Get a diagram and go over everything, check ALL your cables real good. I don't mean look at them. I mean pull and tug on each one, chceck for corrosion or loose connections. If you have to, take them off ONE AT A TIME, clean them real good and reconnect. Check EACH batteries water level too. You could have a bad battery in the mix and it will cause similar symptoms.
roady89 is offline   Reply With Quote
Unread 07-17-2009, 12:57 PM   #5
Not Yet Wild
 
Join Date: Jul 2009
Posts: 7
Default Re: golf cart regen 1 1997 need help please

thanks yamaha i will check on that all the connection and silinoid is good thu ill see what i can do thanks again
hanivw is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Charging problem 1996 Club Car 48V DS non-regen cart Electric Club Car
2001 CC Regen Cart Electric Club Car
1997 yamaha gas g16a cart oil change? Gas Yamaha
How to test MCOR on 04 IQ regen cart Electric Club Car
1997 ezgo txt electric cart quit running need help Electric EZGO


All times are GMT -5. The time now is 12:07 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.