lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 07-26-2009, 09:24 PM   #1
Not Yet Wild
Club Car
 
Join Date: Jul 2009
Location: athens ga
Posts: 24
Default nub charging question

Ok since i just got new batts and cables on this oo 48volt graveyard cart this is the first time charging it. Is it normal to have 60 volts across pack during charging, should i be able to hear the batts bubbling. again im nub so go easy on me.
athens27 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 07-27-2009, 09:02 AM   #2
Not Yet Wild
 
Join Date: Jul 2009
Posts: 11
Default Re: nub charging question

Yes that sounds normal. The 60 amps is higher then I've seen but someone else will hopefully add to this.

Jim
jamby is offline   Reply With Quote
Unread 07-27-2009, 09:09 AM   #3
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,086
Default Re: nub charging question

Yes that is normal.... let the charger finish and check the voltage 30-45 minutes after the charger shuts off ... you should have a reading like on the chart below. During the first 12 cycles it is important to always let the charge finish and do not draw the pack down below say 75% capacity..... then never below 50% during their useable life. If you do this they will last about twice as long as an abused set
Attached Images
File Type: jpg StateofChargeChart.jpg (53.8 KB, 14 views)
scottyb is online now   Reply With Quote
Unread 07-27-2009, 12:18 PM   #4
Not Yet Wild
Club Car
 
Join Date: Jul 2009
Location: athens ga
Posts: 24
Default Re: nub charging question

awsome guys thanks for the response. I let it charge over night (never unplugged it) and it was off this morning. My total pack voltage is 51.3, now when my solenoid gets here wend. i can finally drive it.
athens27 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
charging system question Gas Club Car
Charging Question Electric EZGO
charging question Electric EZGO
Another Charging Question Electric Club Car
charging question Electric EZGO


All times are GMT -5. The time now is 12:51 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.