lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 10-19-2009, 09:51 AM   #11
Not Yet Wild
 
Join Date: Jul 2009
Posts: 20
Default Re: electric 96cc still having solenoid/want run problems

I am having a very similar problem with my 1997 CC DS. The wiring diagram suggests a late REGEN or IQ. There are two solenoids. The first one clicks when I turn the key, the engine appears to whine a bit, but the cart will not go. All I do to correct this is I jump the large terminals of that first solenoid (the one that clicked when I turned the key) and the cart runs fine. The engine still has the whine but then when I hit the pedal, the other solenoid (the one with the large resistor coil) clicks and the cart runs nice. I replaced the solenoid, only to discover that the new one behaved the same way. Any thoughts on what it could be and how I can test voltages to isolate the problem. Also, should I be concerned about keeping the solenoid jumped? Stephen
frogbridge is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 10-19-2009, 01:02 PM   #12
just leave me alone
 
GLEEMO's Avatar
Club Car
 
Join Date: Aug 2008
Location: Tennessee
Posts: 5,643
Default Re: electric 96cc still having solenoid/want run problems

Hey "frogbridge" it's hard to trouble shoot 2 user problems in 1 thread , start a new thread Please ! THANKS !

PS: the first Solinoid is Regen Breaking and is supposed to click when key is on.
GLEEMO is offline   Reply With Quote
Unread 10-20-2009, 01:11 AM   #13
Not Yet Wild
 
Join Date: Jul 2009
Posts: 20
Default Re: electric 96cc still having solenoid/want run problems

Sorry. I created a new thread. Good luck troubleshooting.
frogbridge is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
1989 electric Par Car solenoid issues Columbia ParCar
Kiwasaki Rear-end shaft play in 96CC Electric Club Car
Solenoid problems Electric Club Car
Solenoid problems Electric Club Car
EZ-GO Electric with problems Electric EZGO


All times are GMT -5. The time now is 09:29 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.