lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 08-28-2009, 05:12 PM   #1
Not Yet Wild
 
Join Date: Aug 2009
Posts: 2
Default 96 CC DS starts out slow in both R & F

My first thread on this forum and my first experience with a golf cart. I have been monitoring the forum for about a month now. My Mom has a 48V 96 CC DS Power Glide Plus. S/N A9641-535074. She has had the cart for about 2 years. The man we bought if from told us that the "computer" wasn't working right and that he had jumpered the cart so it would run--the only thing is that it starts off slow and then soon goes to normal speed both in forward or reverse. The jumper wire is fused and is connected from the negative pole of the battery pack to one of the two solenoids on board. When the key is turned on, the solenoid clicks. (I don't remember hearing a click when the go pedal is pressed). I have not seen any arcing in the F & R rocker switch. It has been working fine and has 8V Interstate batteries all stamped G 7. The batteries seem to take a long time to charge and the last charge seemed to take longer than usual and the charger got down to 4 amps and never shut off after about 12 hours. I have not checked the voltage on the batteries and am charging them as I am writing this. Could it be the controller that is faulty? And are we flirting with disaster to run this thing jumpered the way it is? After seeing the prices for controllers, it's no wonder the man didn't replace it. It has a GE controller.
tbran is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 08-29-2009, 05:48 PM   #2
Not Yet Wild
 
Join Date: Aug 2009
Posts: 2
Default Re: 96 CC DS starts out slow in both R & F

Hello again to all. Further information on my post yesterday: The batteries recharged correctly and the charger shut off. Voltages measured are as follows:
Bat 1: 8.2 volts
Bat 2: 8.2 volts
Bat 3: 8.2 volts
Bat 4: 8.1 volts
Bat 5: 8.1 volts
Bat 6: 8.0 volts
Voltage across all batteries: 50.1 volts
So it appears the batteries are ok?? Thanks for any help on the controller issue.
tbran is offline   Reply With Quote
Unread 08-29-2009, 08:56 PM   #3
Gone Wild
 
tonyton's Avatar
E-Z-GO
 
Join Date: Jan 2009
Location: Alabama
Posts: 2,120
Default Re: 96 CC DS starts out slow in both R & F

Your battery voltage is barely OK. If that is freshly charged, it's probably not OK. Have you serviced the batteries and/or cleaned the terminals?? I would check and add water, remove, clean and re-install the battery cables.(one at a time) Then charge it again to see if the voltage has improved. Also, the tire air pressure is vital to the performance of these carts. Be sure it is up to recommended psi. That will help for starters. If you have done these disregard this....
Welcome to the forum!!
Someone else will know more about the controller issue and testing...
tonyton is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
new plugs cart starts slow Gas EZGO
Slow! How do I make my club car Gasser go really slow. Gas Club Car
85 cc jerky starts Electric Club Car
starts when key is turned Gas EZGO
Rain is gone....now the fun starts Lifted Golf Carts


All times are GMT -5. The time now is 05:59 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.