lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 08-30-2009, 04:00 PM   #1
Not Yet Wild
 
Join Date: Aug 2009
Posts: 2
Default 03 Club Q Car no voltage

I have a 2003 Club Q Car with issues.
First I lost a battery post probably because of a loose connection. I replaced the battery. The warning light went on for 25 seconds, off for 5 seconds, on for 5 seconds, off for five seconds, then repeat the series, Then the charger went out. I got a new used charger. The cart was working fine but weak. I found out I had a dead short ground from another battery. Replaced this battery and fixed the short. Charged the cart and then had no voltage across the series. The cart warning light is now acting normal when turned on. I disconnected and ohmed out all the battery cables and got voltage over 8 volts on each battey. When I hooked it back up the OBC will click when the pedal is engaged in reverse bit not go. I have checked and re-checked the cables to insure the series is correct. I bybassed the OBC from the Yellow wire terminal to the negative post ane the cart did not run indicating the OBC should be OK. All terminal posts are corrossion free with sound connections. I have owned and serviced personal electric carts for 9 years and a perplexed as to why I do not get any voltage across the series.
Thanking you in advance for any ideas....
Steve
stevennelesen is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 08-30-2009, 04:32 PM   #2
Gone Wild
E-Z-GO
 
Join Date: Mar 2009
Location: At the race track(Texas)
Posts: 946
Default Re: 03 Club Q Car no voltage

What two cables did you disconnect to get your total pack reading?

WELCOME TO THE BGW FORUM!!!!!!!!!!!!
GarageBuilt is offline   Reply With Quote
Unread 08-31-2009, 09:13 AM   #3
Not Yet Wild
 
Join Date: Aug 2009
Posts: 2
Default Re: 03 Club Q Car no voltage

Thanks for the quick reply.
I did not disconnect the negative from the # 1 (Ground to the OBC) and positive from the # 6 (Power to the Coil). I pressed the accelerator to check the voltage and it read zero with and without the accelerator depressed. I am going to test the batteries with a load tester next weekend. A mechanic friend recommended I check the coil. I have the procedure from the Buggiues Unlimited Cart Docotor web site.
stevennelesen is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
voltage Gas EZGO
More Voltage! Electric EZGO
Voltage sag ??? Extreme DC!
voltage gap Gas EZGO
Low Voltage Electric golf carts


All times are GMT -5. The time now is 12:12 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.