lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 09-09-2009, 12:30 PM   #1
Not Yet Wild
 
Join Date: Sep 2009
Posts: 1
Default '03 electric club car wont go

The car was running fine one minute, I stopped for a minute, and when I got back on...... nothing, I could hear the "click" of the motor when you first hit the gas, but that was it... there was no go. So I took a look underneath at the motor and the heavy white wire had melted/broken. I repaired that but still no go, I noticed that something smelled hot, and started feeling around the undercarriage for something warm. I couldn't really see what it was (kinda cramped under there) but it was pretty hot and it was on the driver side just in front and above the motor. We really use this thing a lot, so I hope it can be repaired rather easily. Any ideas would be appreciated.
03 electric is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 09-10-2009, 08:56 AM   #2
just leave me alone
 
GLEEMO's Avatar
Club Car
 
Join Date: Aug 2008
Location: Tennessee
Posts: 5,643
Default Re: '03 electric club car wont go

Normally when overheating is involved it is loose connection some place.

Check all Battery connections + connections of other Heavy gage wires.
Clean and tighten all , make sure ends are not frayed or corroded.
Clean and clean all battery post.
Clean Battery surfaces remove Oil, acid ...etc these can build up a charge.

Check fluid levels in batteries if low add distilled water.
Place unit on charger until charge completes wait 30 Minutes then take the battery pack
reading with a digital Volt meter and

POST results here !
GLEEMO is offline   Reply With Quote
Unread 09-10-2009, 09:03 AM   #3
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,042
Default Re: '03 electric club car wont go

Quote:
Originally Posted by 03 electric View Post
The car was running fine one minute, I stopped for a minute, and when I got back on...... nothing, I could hear the "click" of the motor when you first hit the gas, but that was it... there was no go. So I took a look underneath at the motor and the heavy white wire had melted/broken. I repaired that but still no go, I noticed that something smelled hot, and started feeling around the undercarriage for something warm. I couldn't really see what it was (kinda cramped under there) but it was pretty hot and it was on the driver side just in front and above the motor. We really use this thing a lot, so I hope it can be repaired rather easily. Any ideas would be appreciated.
If you meant on the driver's side then this is where the solenoid is located? Along with the OBC ..... A far as simple to fix? If the cart has a toggle switch F&R and a Run/Tow switch under the seat? Then it is an IQ cart and unfortunately..... there is nothing simple about this cart electronically speaking.
scottyb is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
83 electric club car wont run Electric Club Car
86 electric club car wont move Electric Club Car
Electric EZ Go Wont Go Electric EZGO
Electric Club Car wont Go-2 Electric Club Car
Electric Club Car wont Go!! Electric Club Car


All times are GMT -5. The time now is 04:26 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.