lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 09-15-2009, 09:03 PM   #11
Not Yet Wild
Club Car
 
Join Date: Aug 2008
Location: Central NY
Posts: 37
Default Re: 96 club car wont go...

Quote:
Originally Posted by scottyb View Post
It could be can you confirm that you have an MCOR throttle indicator mouunted under the Passenger side floor and connected to the gas peddle?
I can't quite see clearly but there is a square box mounted in the central area under the floor.
timgman is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 09-15-2009, 09:14 PM   #12
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,042
Default Re: 96 club car wont go...

96 could be either maybe a potentiometer in the black box or if on the Pass side, mounted on the pass side of the main frame then it is a MCOR?
scottyb is offline   Reply With Quote
Unread 09-15-2009, 09:27 PM   #13
Not Yet Wild
Club Car
 
Join Date: Aug 2008
Location: Central NY
Posts: 37
Default Re: 96 club car wont go...

Quote:
Originally Posted by scottyb View Post
96 could be either maybe a potentiometer in the black box or if on the Pass side, mounted on the pass side of the main frame then it is a MCOR?
Yeah I'd guess this is a POT.. It's mounted centrally.
Could this be the issue?
timgman is offline   Reply With Quote
Unread 09-15-2009, 10:09 PM   #14
Gone Crazy
 
Join Date: Jan 2007
Location: Chesterfield, Va
Posts: 5,064
Default Re: 96 club car wont go...

Scotty you know I'm not much on electrics but since the last thing he did was charge it how about the safety interloc in the charger receptical?
crash12888 is offline   Reply With Quote
Unread 09-23-2009, 08:52 PM   #15
Not Yet Wild
Club Car
 
Join Date: Aug 2008
Location: Central NY
Posts: 37
Default Re: 96 club car wont go...

Still having the issue.
When I first turn the key on and put her in "F" then hit the pedal it does "tunk foreward" just slightly..
any Ideas?
I tested all 6 batteries. they varry from 8.2 - 8.4 volts.
The wires all seem to have good connections...

thanks
timg
timgman is offline   Reply With Quote
Unread 09-24-2009, 01:09 PM   #16
Not Yet Wild
Club Car
 
Join Date: Aug 2009
Location: Western New York
Posts: 21
Default Re: 96 club car wont go...

Quote:
Originally Posted by crash12888 View Post
Scotty you know I'm not much on electrics but since the last thing he did was charge it how about the safety interloc in the charger receptical?
I don't want to steal tingmans thread but I have the same dead cart. What is this interlock to mention, how does it work & how do you test or reset it?
scobar is offline   Reply With Quote
Unread 09-24-2009, 01:46 PM   #17
Not Yet Wild
Club Car
 
Join Date: Aug 2008
Location: Central NY
Posts: 37
Default Re: 96 club car wont go...

Please do post here;;; ant attention is good sttention ;)
timgman is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Club Car wont take charge Electric Club Car
Club car wont run Electric Club Car
91 club car wont go Electric Club Car
36v club car wont run!! Electric Club Car
club car wont go Electric Club Car


All times are GMT -5. The time now is 08:16 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.