lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 09-14-2009, 09:00 PM   #1
Not Yet Wild
Club Car
 
Join Date: Aug 2008
Location: Central NY
Posts: 37
Default 96 club car wont go...

I just bought a 96 club car off ebay and it wont move.. I drove it the first day without any issues, put it on the charger over nite' and now it does nothing...
I can hear the pedal activate a servo or something but it does not move. I checked for loose connection at the batteries and they seemed tight. the guy said he had put 2 new batteries in a while ago and had not had any issues...
any Ideas?
thanks
timg
timgman is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 09-14-2009, 09:08 PM   #2
Not Yet Wild
Club Car
 
Join Date: Aug 2008
Location: Central NY
Posts: 37
Default Re: 96 club car wont go...

btw it's a 48v.
timgman is offline   Reply With Quote
Unread 09-14-2009, 09:25 PM   #3
Not Yet Wild
Club Car
 
Join Date: Aug 2008
Location: Central NY
Posts: 37
Default Re: 96 club car wont go...

Just ran a voltmeter on the battery circuit and they are all above 8 volts.. total being 49.6 volts.

It just seems that whatever connects the pedal to the motor is not... connecting. The F/R switch seems to have all clean connections.



thanks
timg
timgman is offline   Reply With Quote
Unread 09-15-2009, 10:04 AM   #4
just leave me alone
 
GLEEMO's Avatar
Club Car
 
Join Date: Aug 2008
Location: Tennessee
Posts: 5,643
Default Re: 96 club car wont go...

Will it go in reverse ?, does the reverse buxxer work ?
GLEEMO is offline   Reply With Quote
Unread 09-15-2009, 08:27 PM   #5
Not Yet Wild
Club Car
 
Join Date: Aug 2008
Location: Central NY
Posts: 37
Default Re: 96 club car wont go...

Never had a reverse buzzer.. and no It wont go foreward or backwards.
thanks for the response.
timg
timgman is offline   Reply With Quote
Unread 09-15-2009, 08:36 PM   #6
just leave me alone
 
GLEEMO's Avatar
Club Car
 
Join Date: Aug 2008
Location: Tennessee
Posts: 5,643
Default Re: 96 club car wont go...

OK so I am assuming you have a Voltmeter , if not buy one a digital please !
Take reading across entire pack, from + Posative on Battery to - Neg on Battery #6.

Post results here
GLEEMO is offline   Reply With Quote
Unread 09-15-2009, 08:46 PM   #7
Not Yet Wild
Club Car
 
Join Date: Aug 2008
Location: Central NY
Posts: 37
Default Re: 96 club car wont go...

Quote:
Originally Posted by timgman View Post
Just ran a voltmeter on the battery circuit and they are all above 8 volts.. total being 49.6 volts.

It just seems that whatever connects the pedal to the motor is not... connecting. The F/R switch seems to have all clean connections.



thanks
timg

Does this sound about right? BTW I have a digital VM..
timgman is offline   Reply With Quote
Unread 09-15-2009, 08:50 PM   #8
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,093
Default Re: 96 club car wont go...

It could be can you confirm that you have an MCOR throttle indicator mouunted under the Passenger side floor and connected to the gas peddle?
scottyb is offline   Reply With Quote
Unread 09-15-2009, 09:00 PM   #9
just leave me alone
 
GLEEMO's Avatar
Club Car
 
Join Date: Aug 2008
Location: Tennessee
Posts: 5,643
Default Re: 96 club car wont go...

Quote:
Originally Posted by gmorrison View Post
OK so I am assuming you have a Voltmeter , if not buy one a digital please !
Take reading across entire pack, from + Posative on Battery to - Neg on Battery #6.

Post results here
Sorry gotta learn how to read 49.6 Volts !!!
GLEEMO is offline   Reply With Quote
Unread 09-15-2009, 09:02 PM   #10
Not Yet Wild
Club Car
 
Join Date: Aug 2008
Location: Central NY
Posts: 37
Default Re: 96 club car wont go...

Quote:
Originally Posted by gmorrison View Post
Sorry gotta learn how to read 49.6 Volts !!!
I hear ya' hehe..
I wish I could drive this thing onto some ramps...
hehe
timgman is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Club Car wont take charge Electric Club Car
Club car wont run Electric Club Car
91 club car wont go Electric Club Car
36v club car wont run!! Electric Club Car
club car wont go Electric Club Car


All times are GMT -5. The time now is 07:49 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.