lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 09-22-2009, 05:47 PM   #1
Not Yet Wild
 
Join Date: Sep 2009
Posts: 5
Default 2000 Regen no go

Hey Guys,

I have a 2000 regen that will charge but will not move. It was running great and then it just stopped, almost like a fuse blew, but that wasn't it. I have checked all connections and everything is good. I replaced the soliniod today still no go. One thing I noticed is that the reverse buzzer is no longer working. Any advice or insight would be helpful.

Hoki
hokihigh is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 09-23-2009, 12:15 PM   #2
Not Yet Wild
 
Join Date: Sep 2009
Posts: 5
Default Re: 2000 Regen no go

got it running, turns out I put the blue and blue/white wires in the wrong place, swaped them now it runs like a champ.

Hoki
hokihigh is offline   Reply With Quote
Unread 09-23-2009, 12:17 PM   #3
Gone Crazy
 
miferrel's Avatar
Club Car
 
Join Date: Jun 2008
Location: Mississippi
Posts: 2,176
Default Re: 2000 Regen no go

Quote:
Originally Posted by hokihigh View Post
got it running, turns out I put the blue and blue/white wires in the wrong place, swaped them now it runs like a champ.

Hoki
See what sleeping on it will do...A fresh mind can cure anything. Welcome to the Forum
miferrel is offline   Reply With Quote
Unread 09-23-2009, 08:28 PM   #4
just leave me alone
 
GLEEMO's Avatar
Club Car
 
Join Date: Aug 2008
Location: Tennessee
Posts: 5,643
Default Re: 2000 Regen no go

Just so we/I know , it was a defective Solinoid ?
GLEEMO is offline   Reply With Quote
Unread 09-23-2009, 10:53 PM   #5
Not Yet Wild
 
Join Date: Sep 2009
Posts: 5
Default Re: 2000 Regen no go

Quote:
Originally Posted by gmorrison View Post
Just so we/I know , it was a defective Solinoid ?
Yep
hokihigh is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
97 regen cart...I HATE REGEN BRAKING!! Electric Club Car
2000 regen charge problems Electric Club Car
Regen help Electric Club Car
regen vs std Electric Club Car


All times are GMT -5. The time now is 01:00 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.