lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 10-07-2009, 03:06 PM   #21
Not Yet Wild
 
pghtex's Avatar
Club Car
 
Join Date: Sep 2009
Location: Southwest PA
Posts: 45
Default Re: Problem on 95 cc, need help please.

Yeah no thanks, dont have the money for a shop or a pc.
pghtex is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 10-07-2009, 05:05 PM   #22
Not Yet Wild
 
pghtex's Avatar
Club Car
 
Join Date: Sep 2009
Location: Southwest PA
Posts: 45
Default Re: Problem on 95 cc, need help please.

Ok heres what i got. The solenoid is not clicking when you press the pedal. There are no errors on the controller either. I cant find any broken wires anywhere. I jacked it up and removed the wheels, held the pedal down and the light on the axe stays yellow. But no click. What gives guys?

By the way, I really appreciate your help on this.
pghtex is offline   Reply With Quote
Unread 10-07-2009, 08:36 PM   #23
just leave me alone
 
GLEEMO's Avatar
Club Car
 
Join Date: Aug 2008
Location: Tennessee
Posts: 5,643
Default Re: Problem on 95 cc, need help please.

So when U press the peddle do you have the 48 Volts needed on the small wires at the Solinoid ?

Have you tried Jumping Solinoid ?
GLEEMO is offline   Reply With Quote
Unread 10-07-2009, 08:38 PM   #24
Not Yet Wild
Club Car
 
Join Date: Aug 2009
Posts: 8
Default Re: Problem on 95 cc, need help please.

If the solenoid is not clicking, by-pass the OBC and see if the cart runs or the solenoid engages. Google and/or search the web to see how to bypass the OBC.
Charlie5 is offline   Reply With Quote
Unread 10-07-2009, 08:53 PM   #25
Not Yet Wild
 
pghtex's Avatar
Club Car
 
Join Date: Sep 2009
Location: Southwest PA
Posts: 45
Default Re: Problem on 95 cc, need help please.

Quote:
Originally Posted by gmorrison View Post
So when U press the peddle do you have the 48 Volts needed on the small wires at the Solinoid ?

Have you tried Jumping Solinoid ?
I did jump the solinoid and it does run when I do this. I need to check the small wires, but I didnt think that it would have 48 volts at the small wires. Which wires would show 48?

Thanks!!!
pghtex is offline   Reply With Quote
Unread 10-07-2009, 09:01 PM   #26
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,069
Default Re: Problem on 95 cc, need help please.

The solenoid is a simple on/off switch between the large terminals. it is activated by a positive and a negative current at the 2 small terminals... One of these small terminal charges will be constant and the other switched by a micro switch at the F&R or Accelerator
scottyb is offline   Reply With Quote
Unread 10-08-2009, 08:24 AM   #27
Not Yet Wild
 
pghtex's Avatar
Club Car
 
Join Date: Sep 2009
Location: Southwest PA
Posts: 45
Default Re: Problem on 95 cc, need help please.

Could it be the obc screwing it up? cause I notice theres a wire from the obc to the solenoid.
pghtex is offline   Reply With Quote
Unread 10-08-2009, 09:43 AM   #28
just leave me alone
 
GLEEMO's Avatar
Club Car
 
Join Date: Aug 2008
Location: Tennessee
Posts: 5,643
Default Re: Problem on 95 cc, need help please.

Or it could be the solenoid itself , the least expensive of the 2 to replace.

1. Check to insure Batteries are fully charged 50+ Volts.
if Yes
2. Bypass OBC
2.a If solenoid clicks , check OBC fuses if fuses are good
2.b Try resetting the OBC
GLEEMO is offline   Reply With Quote
Unread 10-08-2009, 11:01 AM   #29
Not Yet Wild
 
pghtex's Avatar
Club Car
 
Join Date: Sep 2009
Location: Southwest PA
Posts: 45
Default Re: Problem on 95 cc, need help please.

Ok I am an idiot! I put the diode on the new solenoid on backwards last week. Would that cause the solenoid to malfunction?
pghtex is offline   Reply With Quote
Unread 10-08-2009, 11:03 AM   #30
just leave me alone
 
GLEEMO's Avatar
Club Car
 
Join Date: Aug 2008
Location: Tennessee
Posts: 5,643
Default Re: Problem on 95 cc, need help please.

YES !
No Idiot just human
GLEEMO is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes



All times are GMT -5. The time now is 03:23 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.