lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 10-14-2009, 06:17 PM   #1
Not Yet Wild
 
jdown1's Avatar
Club Car
 
Join Date: Mar 2009
Location: Hattiesburg, MS
Posts: 27
Question 99 CC has no power at WOT

I have a 99 CC DS and recently it started stalling at WOT. In forward or reverse, it accelerates fine until the accelerator is floored, and it stops. I have the V-Glide opened up and all seems fine. Has anyone else had this problem? Any suggestions or ideas? Thanks
jdown1 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 10-14-2009, 08:52 PM   #2
Not Yet Wild
 
jdown1's Avatar
Club Car
 
Join Date: Mar 2009
Location: Hattiesburg, MS
Posts: 27
Default Re: 99 CC has no power at WOT

Nevermind. I fixed it.
jdown1 is offline   Reply With Quote
Unread 10-15-2009, 12:30 PM   #3
just leave me alone
 
GLEEMO's Avatar
Club Car
 
Join Date: Aug 2008
Location: Tennessee
Posts: 5,643
Default Re: 99 CC has no power at WOT

Quote:
Originally Posted by jdown1 View Post
Nevermind. I fixed it.
OK so was it a broken wire ?
Curious minds want to know ?
GLEEMO is offline   Reply With Quote
Unread 10-15-2009, 10:55 PM   #4
Not Yet Wild
 
jdown1's Avatar
Club Car
 
Join Date: Mar 2009
Location: Hattiesburg, MS
Posts: 27
Default Re: 99 CC has no power at WOT

i couldn't find anything obvious, so I cleaned all of the contacts on the V-Glide and reassembled it, assuming it still wouldn't work. Surprisingly, it did. I guess it's the old "take it apart and put it back together" trick.
jdown1 is offline   Reply With Quote
Unread 10-16-2009, 10:33 AM   #5
just leave me alone
 
GLEEMO's Avatar
Club Car
 
Join Date: Aug 2008
Location: Tennessee
Posts: 5,643
Default Re: 99 CC has no power at WOT

I think you could use some di-electric grease to enhanse contact between the wiper
and studs and also reduce wear ?
GLEEMO is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Power in Reverse/Little Power in Forward Gas Harley Davidson
g2 power Gas Yamaha
more power Big Block Talk!
more power Gas Yamaha
91 G9 has no power-HELP Gas Yamaha


All times are GMT -5. The time now is 01:10 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.