Buggies Gone Wild Golf Cart Forum

Buggies Gone Wild Golf Cart Forum (http://www.buggiesgonewild.com/)
-   Electric Club Car (http://www.buggiesgonewild.com/electric-club-car/)
-   -   Final battery connect sparks (http://www.buggiesgonewild.com/electric-club-car/27372-final-battery-connect-sparks.html)

Datawave 12-26-2009 08:55 AM

Final battery connect sparks
 
Firstly, what a fantastic forum and participation.
I just bought a '90 36vdc Club Car from a friend. It was driven to my house from a few blocks down the road. When I took it later in the day it barely had enough power to get it to the charger. The batts were '03 t605's. I put it on charge for close to 12 hours to see if I could get anything out of them. The charger stayed at 25-30 amps. The forward/reverse swith was in forward during the charge, the key was off. I checked the SG and float levels and the batts weren't coming back. I replaced them with a new string of 105's and when connecting the last connection..which was the most positive I get a large spark. If I moved the F/R switch to neutral I can connect. I didn't change any wiring other than the batts. I don't want to ruin the new batts or do any further welding. Am doing something wrong procedurely? I'm afraid I may have shorted the motor during the charge? Any guidance is appreciated.Thanks.

mikesmotortoys 12-26-2009 09:09 AM

Re: Final battery connect sparks
 
Does it not run now with the new batteries?

Frizbgolf 12-26-2009 09:23 AM

Re: Final battery connect sparks
 
Datawave, there should not be any sparks when you connect the batteries unless there is a load. Even with the switch in the forward position there shouldn't be a load until the pedal is pushed. I would recheck the wiring to see if anything is ground and completing the circuit.

goodoleboy80 12-26-2009 09:39 AM

Re: Final battery connect sparks
 
Sounds to me the solenoid is stuck, letting current pass through. I've got an '89 cc and had the same problem last year.

Frizbgolf 12-26-2009 10:51 AM

Re: Final battery connect sparks
 
That is what I was thinking goodoleboy. There has to be something that is letting current pass. I have had a wire that cracked and was touching the frame intermittently kept draining my batts til I found it.

Datawave 12-26-2009 11:19 AM

Re: Final battery connect sparks
 
Everything so far is pointing to a shorted motor..when it is brought into the circut is when the problems begin. Any idea what I should be reading between the windings? I have an 87 Fluke.

GLEEMO 12-27-2009 10:07 AM

Re: Final battery connect sparks
 
#1 always connect the "-" Negative as the last connection.
The Pos + will always spark when removing from Pack if the - Neg is connected.

"Does it not run now with the new batteries?"
Measure the entire pack ans list Volotage here.
Read this http://www.buggiesgonewild.com/elect...-readings.html

Datawave 12-27-2009 12:16 PM

Re: Final battery connect sparks
 
Hooked the most negative last...the cart runs great...thanks to all.

GLEEMO 12-28-2009 10:38 AM

Re: Final battery connect sparks
 
NP have FUN :burnout::thumbup:


All times are GMT -5. The time now is 11:28 PM.

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.