lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 01-22-2010, 11:24 AM   #11
Not Yet Wild
Club Car
 
Join Date: Jan 2010
Location: Kansas
Posts: 25
Default Re: Speed problem with 1998 CC and battery ?

Good morning gmorrison, The batteries charged for 12 hours and I wasn't able to get the reading at 1 hour after the charge (I'm getting old and I need my sleep) I did get the voltage readings this AM
1. 6.33
2. 6.13
3. 6.33
4. 2.23
5. 6.32
6. 6.31

Putting the red tester on #1 positive and the black on #6 the reading was 28.6
I got the wrong type of Hydrometer according to Old Mec. I will exchange today and get those readings. Thanks a lot guys
Randy
Randy L is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 01-22-2010, 11:29 AM   #12
just leave me alone
 
GLEEMO's Avatar
Club Car
 
Join Date: Aug 2008
Location: Tennessee
Posts: 5,643
Default Re: Speed problem with 1998 CC and battery ?

#4 battery is either out of the circuit and not getting re-charged or it is DEAD.

My guess is DEAD.
GLEEMO is offline   Reply With Quote
Unread 01-22-2010, 11:35 AM   #13
Not Yet Wild
Club Car
 
Join Date: Jan 2010
Location: Kansas
Posts: 25
Default Re: Speed problem with 1998 CC and battery ?

If I understand the SOC numbers, 5 of the 6 batteries are ok. With #4 testing so badly what do you suggest. I am going to check to make sure it is wired in correctly as I took all the battries out to clean them and underneath as well.
Randy L is offline   Reply With Quote
Unread 01-22-2010, 11:43 AM   #14
just leave me alone
 
GLEEMO's Avatar
Club Car
 
Join Date: Aug 2008
Location: Tennessee
Posts: 5,643
Default Re: Speed problem with 1998 CC and battery ?

I would either buy 1 new battery or a ,
used Battery from a reptuable shop which has the same amp hour rating and will charge and stay at 6.3 Volts.
GLEEMO is offline   Reply With Quote
Unread 01-22-2010, 12:57 PM   #15
Gone Wild
 
golfcarfixer's Avatar
Club Car
 
Join Date: Sep 2009
Location: DELAWARE
Posts: 2,656
Default Re: Speed problem with 1998 CC and battery ?

Quote:
Originally Posted by gmorrison View Post
I would either buy 1 new battery or a ,
used Battery from a reptuable shop which has the same amp hour rating and will charge and stay at 6.3 Volts.
I agree.
golfcarfixer is offline   Reply With Quote
Unread 01-22-2010, 01:00 PM   #16
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,048
Default Re: Speed problem with 1998 CC and battery ?

After 12 hours of charging Batt #2 is at 50% capacity? That is not good
scottyb is offline   Reply With Quote
Unread 01-22-2010, 01:32 PM   #17
just leave me alone
 
GLEEMO's Avatar
Club Car
 
Join Date: Aug 2008
Location: Tennessee
Posts: 5,643
Default Re: Speed problem with 1998 CC and battery ?

Yep scottyb is right , good catch (all the 3's running together)

What May happen here is that the new Battery would bring the others up a bit ?
But the same theory holds , in the fact that any week battery will cause the good
batteries to drain faster and go bad.
So in a perfect world replace all with new ,
Real world replace at least #4 and #2 , the newer the better.
GLEEMO is offline   Reply With Quote
Unread 01-22-2010, 03:10 PM   #18
Not Yet Wild
Club Car
 
Join Date: Jan 2010
Location: Kansas
Posts: 25
Default Re: Speed problem with 1998 CC and battery ?

It looks like I will be checking around to replace #2 and #4. I had always heard to replace all at once, but I really can't afford that right now.
Randy L is offline   Reply With Quote
Unread 01-22-2010, 05:01 PM   #19
just leave me alone
 
GLEEMO's Avatar
Club Car
 
Join Date: Aug 2008
Location: Tennessee
Posts: 5,643
Default Re: Speed problem with 1998 CC and battery ?

No problem , do what you can , let us know if it helps !
Tell everyone in Kansas I said hey, they'll know what I mean
GLEEMO is offline   Reply With Quote
Unread 01-22-2010, 05:07 PM   #20
Gone Wild
 
OLD MEC's Avatar
Club Car
 
Join Date: Mar 2009
Location: South Texas
Posts: 2,391
Default Re: Speed problem with 1998 CC and battery ?

I would NEVER BUY A NEW BATTERY and install it with USED BATTERYS as you will waste your money by boiling the new one to death trying to bring the old batterys up to full charge.You might check at the local golf course as sometimes they have some used batterys? See the service person and go around the manager of course. I dont like to add more used batterys but like you I more than I like have to spread my funds around as lighley as possible.
BEST WOULD BE TO REPLCE ALL BATTERYS WITH QUALITY REPLACEMENTS.
When you do go after NEW batterys manually pick up a Trojan battery first and then pick up the second best and compare weight. WEIGHT MEANS MORE LEAD AND MORE LEAD MEAN LONGER LIFE AND LONGER RANGE DAILY BEFORE CHARGING.
OLD MEC is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
1998 EZ GO gas golf cart power problem Gas EZGO
1998 EZGO-Gas starting problem Gas EZGO
speed problem xt 500 Electric EZGO
Need for cheap speed 1998 model Electric Club Car


All times are GMT -5. The time now is 02:16 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.