lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 01-27-2010, 10:39 AM   #1
Gone Wild
 
mikesmotortoys's Avatar
E-Z-GO
 
Join Date: Mar 2008
Location: Rockwall, Texas (Dallas / Ft. Worth)
Posts: 7,077
Default Precedent Assistance!

We don't get these in very often, so now I need some help from all of you...

I have a Club Car 48v Precedent in the shop. When you press the pedal in forward, it takes off strong, but soon falls flat on it's face to about 1/2 speed. The batteries discharge OK, so this is not the issue. I'm thinking it can be either the MCOR or the speed sensor on the motor.

Anyone ever have this happen? Thank you for your input

Factory EZGO - Bad Boy Buggy - Dixie Chopper Mowers
mikesmotortoys is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 01-27-2010, 11:39 AM   #2
Gone Wild
 
golfcarfixer's Avatar
Club Car
 
Join Date: Sep 2009
Location: DELAWARE
Posts: 2,656
Default Re: Precedent Assistance!

Quote:
Originally Posted by mikesmotortoys View Post
We don't get these in very often, so now I need some help from all of you...

I have a Club Car 48v Precedent in the shop. When you press the pedal in forward, it takes off strong, but soon falls flat on it's face to about 1/2 speed. The batteries discharge OK, so this is not the issue. I'm thinking it can be either the MCOR or the speed sensor on the motor.

Anyone ever have this happen? Thank you for your input
Its the speed sensor.
golfcarfixer is offline   Reply With Quote
Unread 01-27-2010, 11:44 AM   #3
Gone Wild
 
mikesmotortoys's Avatar
E-Z-GO
 
Join Date: Mar 2008
Location: Rockwall, Texas (Dallas / Ft. Worth)
Posts: 7,077
Default Re: Precedent Assistance!

Quote:
Originally Posted by golfcarfixer View Post
Its the speed sensor.
Thanks That's what I was thinking. Are there two different kinds? This cart has a bolt on sensor, but I see a snap ring style in my parts book (Nivel). Guess I need to call on a favor from my not so local Club Car dealer? (BTW - My local CC dealer won't sell me parts - go figure!)

Factory EZGO - Bad Boy Buggy - Dixie Chopper Mowers
mikesmotortoys is offline   Reply With Quote
Unread 01-27-2010, 11:52 AM   #4
Gone Wild
 
golfcarfixer's Avatar
Club Car
 
Join Date: Sep 2009
Location: DELAWARE
Posts: 2,656
Default Re: Precedent Assistance!

Quote:
Originally Posted by mikesmotortoys View Post
Thanks That's what I was thinking. Are there two different kinds? This cart has a bolt on sensor, but I see a snap ring style in my parts book (Nivel). Guess I need to call on a favor from my not so local Club Car dealer? (BTW - My local CC dealer won't sell me parts - go figure!)
Thats strange,looks like that # is 9451 that will be a piece of cake to change.I probably change about 2 a year. never changed one on an ezgo.
golfcarfixer is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
BB kit for 07 precedent available Big Block Talk!
need assistance Electric Club Car
30+ mph possible for 04 precedent? Electric Club Car
Precedent Electric Club Car
Newbie needs assistance Electric EZGO


All times are GMT -5. The time now is 02:15 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.