lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 03-13-2010, 02:02 AM   #11
Gone Wild
 
Fishing Dude's Avatar
Club Car
 
Join Date: Jul 2008
Location: Slums of Lake Erie
Posts: 3,722
Default Re: 2001 installed new mcor, now wont do anything

Does the solenoid click?
Fishing Dude is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 03-13-2010, 07:45 AM   #12
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,053
Default Re: 2001 installed new mcor, now wont do anything

Quote:
Originally Posted by tinab View Post
hi - a little background on how i got where i am...

'inherited' my '01 clubcar. it had only been used a couple times in the last 3 years. it had new batteries put in a couple years ago. last year it had a couple eroded wires replaced.

when i got it, drove it a few minutes, ran fine. got in it later that day, it started out ok but lost power pretty quick. if i let up on the gas then push it back to the floor, it would gain power, but then loose it. didn't drive it for a couple months after that.

got in it last weekend, it drove fine for a few hundred feet, then started to slow down. every time i pressed the gas pedal it would move a couple feet then stop (took forever to get back home lol).

called the guy who worked on it last and he said i needed a new mcor. i installed the new mcor today and now it wont do anything. i uninstalled it, had the hubby press on the gas so i could make sure the rod was sitting properly, verified that it was turning when the gas pedal was pressed, retightened everything back up and it still wont do anything.

any ideas? thank you so much for any help - oh, and i really dont know very much about golf carts, so if you could speak in layman's terms that would be wonderful


Everything I have highlighted in red is a red flag about your battery pack condition... The first thing an EV tech does is establish the battery pack charge. Once we have established that you have the proper voltage present we can go on to diagnose the cart's problem.... I suggest you keep the receipt for that MCOR for now.
Guessing that you have the more common 48v model, each battery should read 8.3 - 8.4 volts. the pack as a whole should read 50.91 full and about 48.4 empty...... You will need a digital voltmeter and the chart below.
Attached Images
File Type: jpg Batterytable1-1.jpg (88.7 KB, 19 views)
scottyb is offline   Reply With Quote
Unread 03-13-2010, 08:08 PM   #13
just leave me alone
 
GLEEMO's Avatar
Club Car
 
Join Date: Aug 2008
Location: Tennessee
Posts: 5,643
Default Re: 2001 installed new mcor, now wont do anything

Quote:
Originally Posted by scottyb View Post
Everything I have highlighted in red is a red flag about your battery pack condition... The first thing an EV tech does is establish the battery pack charge. Once we have established that you have the proper voltage present we can go on to diagnose the cart's problem.... I suggest you keep the receipt for that MCOR for now.
Guessing that you have the more common 48v model, each battery should read 8.3 - 8.4 volts. the pack as a whole should read 50.91 full and about 48.4 empty...... You will need a digital voltmeter and the chart below.
GLEEMO is offline   Reply With Quote
Unread 03-13-2010, 08:48 PM   #14
Not Yet Wild
 
Join Date: Mar 2010
Posts: 16
Default Re: 2001 installed new mcor, now wont do anything

i have an analog volt meter (sorry, no digital) but i just tested all of the batteries and they were all above the 8 mark (between 8.2 and 8.4 for all of them).

i do find it strange that the cart was at least working (albeit badly) before i changed out the mcor, and now it doesn't work at all, leading me to believe i have installed the mcor incorrectly?

when i took out the old mcor, the rod that sticks into fell out and i did not see how or where the other end of the rod connected. now that i installed the new mcor, the rod has some play to it (pulls in and out a couple centimeters) and i'm pretty sure that's not supposed to be the case? i cannot find any diagrams that show how the rod is supposed to be hooked up tho.

thank you all again :)
tinab is offline   Reply With Quote
Unread 03-13-2010, 09:03 PM   #15
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,053
Default Re: 2001 installed new mcor, now wont do anything

I don't know what they call them, those serrated rods? or a star rod are just another one of CC stupid ideas They are real sloppy after a few years of use, But that should not make your cart not go at all so put the old mcor back in and see what you have..... also an analog meter is as good as speed dialing on a rotary phone
No where near the accuracy we need... but if you insist upon working with it we will try Can you give me a pack voltage?
scottyb is offline   Reply With Quote
Unread 03-13-2010, 09:25 PM   #16
Gone Wild
 
Join Date: Feb 2009
Location: Not sure yet
Posts: 500
Default Re: 2001 installed new mcor, now wont do anything

You can't put the MCOR in wrong, not even the rod will go in wrong. Battery Pack voltage is fine. I didn't see where you answered if the solenoid clicks? Double check the 2 plug ins and make sure they are fully seated.
FIXEROFCARTS is offline   Reply With Quote
Unread 03-13-2010, 09:29 PM   #17
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,053
Default Re: 2001 installed new mcor, now wont do anything

Quote:
Originally Posted by FIXEROFCARTS View Post
You can't put the MCOR in wrong, not even the rod will go in wrong. Battery Pack voltage is fine. I didn't see where you answered if the solenoid clicks? Double check the 2 plug ins and make sure they are fully seated.
Okay, You fix the cart with his hands. But don't leave him hanging.....
scottyb is offline   Reply With Quote
Unread 03-13-2010, 09:51 PM   #18
Gone Wild
 
golfcarfixer's Avatar
Club Car
 
Join Date: Sep 2009
Location: DELAWARE
Posts: 2,656
Default Re: 2001 installed new mcor, now wont do anything

The MCOR switch is a simple plug and play and you cant switch the wires,I think there is another problem lurking in this thread,It could be a controller getting hot and cutting off.
golfcarfixer is offline   Reply With Quote
Unread 03-13-2010, 09:54 PM   #19
Not Yet Wild
 
Join Date: Mar 2010
Posts: 16
Default Re: 2001 installed new mcor, now wont do anything

how do i get the pack voltage? i dont have access to a digital voltmeter, so this will have to work for right now - sorry :(

how do i tell if the solenoid is clicking - is that click i hear when i push the gas pedal?

when i was putting the star(?) rod into the mcor it did only go in one way, and the other end seemed to sit on the metal plate w/ the smiley face in it (real technical, i know lol) only one way. when i press the gas pedal the rod turns, the mcor is tight on the frame, and the connectors are seated as tight as i could get them.
tinab is offline   Reply With Quote
Unread 03-13-2010, 10:01 PM   #20
Gone Wild
 
golfcarfixer's Avatar
Club Car
 
Join Date: Sep 2009
Location: DELAWARE
Posts: 2,656
Default Re: 2001 installed new mcor, now wont do anything

Quote:
Originally Posted by tinab View Post
how do i get the pack voltage? i dont have access to a digital voltmeter, so this will have to work for right now - sorry :(

how do i tell if the solenoid is clicking - is that click i hear when i push the gas pedal?

when i was putting the star(?) rod into the mcor it did only go in one way, and the other end seemed to sit on the metal plate w/ the smiley face in it (real technical, i know lol) only one way. when i press the gas pedal the rod turns, the mcor is tight on the frame, and the connectors are seated as tight as i could get them.
Well you have done good,as the mcor can only go one way.When you put the padel down it will make an audible CLICK.You can get a digital voltmeter at sears for about 25.00 bucks and you need one for an electric car.I have one from there and it works great.Let us know what its doing next so we can get ya goin.
golfcarfixer is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
wanted: used MCOR for 2001 club car ds Golf Carts and Parts
mcor rebuild 2001 club car Electric Club Car
2001 CC gas wont start? Gas Club Car
Mcor Electric Club Car
mcor Electric Club Car


All times are GMT -5. The time now is 07:44 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.