lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 03-13-2010, 10:05 PM   #21
Not Yet Wild
 
Join Date: Mar 2010
Posts: 16
Default Re: 2001 installed new mcor, now wont do anything

ok, so when i lifted up the seat to check the batteries, i saw that the 2 batteries on the steering wheel side have some corroded connections (blue ick all around it). also, i would occasionally hear a noise that sounded kind of like static, and i wasn't touching anything or moving the cart, etc. that only happened a couple times. does that give any more clues?

ya'll rock - thanks so much :)
tinab is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 03-13-2010, 10:24 PM   #22
Gone Wild
 
golfcarfixer's Avatar
Club Car
 
Join Date: Sep 2009
Location: DELAWARE
Posts: 2,656
Default Re: 2001 installed new mcor, now wont do anything

Quote:
Originally Posted by tinab View Post
ok, so when i lifted up the seat to check the batteries, i saw that the 2 batteries on the steering wheel side have some corroded connections (blue ick all around it). also, i would occasionally hear a noise that sounded kind of like static, and i wasn't touching anything or moving the cart, etc. that only happened a couple times. does that give any more clues?

ya'll rock - thanks so much :)
Yes it does,you need to clean the battery cables.If you have a tow/run switch put it in tow and disconect the main cables,take the cables off and clean the battery posts with a wire brush. if the cables look bad get a new set.make sure you cant move the eyes on the main terminal easy with you r finger.If yo can that eyelet needs replacing.You have batteries arking because of loose cables.
golfcarfixer is offline   Reply With Quote
Unread 03-13-2010, 10:39 PM   #23
Not Yet Wild
 
Join Date: Mar 2010
Posts: 16
Default Re: 2001 installed new mcor, now wont do anything

i will attack the corrosion problem tomorrow and let you know what happens. thanks!!
tinab is offline   Reply With Quote
Unread 03-14-2010, 12:56 AM   #24
Gone Wild
 
Join Date: Feb 2009
Location: Not sure yet
Posts: 500
Default Re: 2001 installed new mcor, now wont do anything

Quote:
Originally Posted by tinab View Post
ok, so when i lifted up the seat to check the batteries, i saw that the 2 batteries on the steering wheel side have some corroded connections (blue ick all around it). also, i would occasionally hear a noise that sounded kind of like static, and i wasn't touching anything or moving the cart, etc. that only happened a couple times. does that give any more clues?

ya'll rock - thanks so much :)
That should be the first thing you check.
FIXEROFCARTS is offline   Reply With Quote
Unread 03-15-2010, 05:40 PM   #25
just leave me alone
 
GLEEMO's Avatar
Club Car
 
Join Date: Aug 2008
Location: Tennessee
Posts: 5,643
Default Re: 2001 installed new mcor, now wont do anything

Quote:
Originally Posted by tinab View Post
i have an analog volt meter (sorry, no digital) but i just tested all of the batteries and they were all above the 8 mark (between 8.2 and 8.4 for all of them).

i do find it strange that the cart was at least working (albeit badly) before i changed out the mcor, and now it doesn't work at all, leading me to believe i have installed the mcor incorrectly?

when i took out the old mcor, the rod that sticks into fell out and i did not see how or where the other end of the rod connected. now that i installed the new mcor, the rod has some play to it (pulls in and out a couple centimeters) and i'm pretty sure that's not supposed to be the case? i cannot find any diagrams that show how the rod is supposed to be hooked up tho.

thank you all again :)
If you tested the batteries earlier , DID U not notice thos big green lumpy things on the battery cable/connectors until now
GLEEMO is offline   Reply With Quote
Unread 03-15-2010, 07:08 PM   #26
Not Yet Wild
 
Join Date: Mar 2010
Posts: 16
Default Re: 2001 installed new mcor, now wont do anything

it would make sense that that cleaning the corrosion would have been the 1st thing done, but i am the first to tell you we never make sense :)

so i cleaned all the corrosion and tightened everything up. i put the old mcor back on and at least it is back to running badly. so now i have to try and exchange the new mcor that doesn't work, but i have a 2 hour drive to get the part so i dont know when that will happen.

thanks everyone for all your help!! :)
tinab is offline   Reply With Quote
Unread 03-15-2010, 10:07 PM   #27
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 7,981
Default Re: 2001 installed new mcor, now wont do anything

Quote:
Originally Posted by tinab View Post
we are not sure of the volts - i will have to try and figure that out tomorrow - we can't tell just by looking @ them.

the mcor looks the same as the one i took off and i was told by the parts guy where i got it (golf cart dealer) that there is only 1 mcor possible for my cart?

i really know very little, thank you for being so patient :)
This is true. Club Car only has 2 MCOR units. One for the DS, and one for the Precedent. If the drive bar fits the MCOR, it's the right one. The precedent one will not fit your car, and even if it did, it would work. All the internals are the same.
TahoeDawgZ71 is offline   Reply With Quote
Unread 03-16-2010, 10:35 AM   #28
just leave me alone
 
GLEEMO's Avatar
Club Car
 
Join Date: Aug 2008
Location: Tennessee
Posts: 5,643
Default Re: 2001 installed new mcor, now wont do anything

K , so now since we are at the beginning,
1. When U take the old MCOR back , get a digital Volt meter .
2. Check Battery water levels , fill to 1/2" above plates (distilled water only)
3. Put the cart on the charger and allow it to complete it's charge cycle .
4. Wait 1 hour after charge completes then with your new Digital Volt meter
measure each battery, then entire pack ,
5. POST results here !
GLEEMO is offline   Reply With Quote
Unread 03-16-2010, 09:54 PM   #29
Not Yet Wild
 
Join Date: Mar 2010
Posts: 16
Default Re: 2001 installed new mcor, now wont do anything

i would like some opinions please -

assuming my batteries are fine, what else could cause the 'catching' or 'jerking' when i press the gas pedal? it does it in both forward and reverse. it seems to have a good bit of speed until it stops/jerks, then i have to press the gas pedal again to get it to go again. the cart runs jerky w/ the original mcor installed, but when i installed the brand new mcor i got absolutely nothing.

is there a way to tell if it is the mcor or the controller causing the problem?
tinab is offline   Reply With Quote
Unread 03-17-2010, 01:38 PM   #30
just leave me alone
 
GLEEMO's Avatar
Club Car
 
Join Date: Aug 2008
Location: Tennessee
Posts: 5,643
Default Re: 2001 installed new mcor, now wont do anything

Or the batteries assuming they are bad ?
GLEEMO is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
wanted: used MCOR for 2001 club car ds Golf Carts and Parts
mcor rebuild 2001 club car Electric Club Car
2001 CC gas wont start? Gas Club Car
Mcor Electric Club Car
mcor Electric Club Car


All times are GMT -5. The time now is 08:23 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.