lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 03-22-2010, 12:35 AM   #1
Getting Wild
Club Car
 
Join Date: Mar 2010
Posts: 76
Cool New Motor?

hey guys, i just bought a 96 v-glide 36v resistor cart and need some more torque to get up and down the mountain golf courses in my area.
what do you guys recomend? any help is appreciated. thanks so much for the site. new motor?
ramjet is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 03-22-2010, 01:53 AM   #2
Moderator
 
rib33024's Avatar
E-Z-GO
 
Join Date: Apr 2009
Location: FT Lauderdale FL.
Posts: 13,159
Default Re: New Motor?

Quote:
Originally Posted by ramjet View Post
hey guys, i just bought a 96 v-glide 36v resistor cart and need some more torque to get up and down the mountain golf courses in my area.
what do you guys recomend? any help is appreciated. thanks so much for the site. new motor?



Any mods done to the cart???---what year are the batteries. and can we get a reading of the battery pack, and each battery. and post the readings here--
rib33024 is offline   Reply With Quote
Unread 03-22-2010, 02:12 AM   #3
Getting Wild
Club Car
 
Join Date: Mar 2010
Posts: 76
Default Re: New Motor?

no mods dont to the cart. i have tested the batts and the all ran between 6.3 an 6.5 on a full charge. they date apr of 08 ive ran the car for three days now after the charge. speed has been good, just really slows down going up hill an when on grass vs hard surface. also notice a big diffrence with another rider
ramjet is offline   Reply With Quote
Unread 03-22-2010, 01:30 PM   #4
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 7,981
Default Re: New Motor?

Quote:
Originally Posted by ramjet View Post
no mods dont to the cart. i have tested the batts and the all ran between 6.3 an 6.5 on a full charge. they date apr of 08 ive ran the car for three days now after the charge. speed has been good, just really slows down going up hill an when on grass vs hard surface. also notice a big diffrence with another rider
It's the nature of the beast man. It's a 36V car. That's how all of them are. You can put a motor in it with more torque but you're gonna sacrifice speed if you do.
TahoeDawgZ71 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
throttle linkage Gas Columbia ParCar
Finally the linkage Gas Yamaha
Throttle Linkage Big Block Talk!
V-Glide doesn't glide - 1992 36v Electric Club Car
G1 gas linkage Gas Yamaha


All times are GMT -5. The time now is 03:51 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.