lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 03-26-2010, 03:55 PM   #1
Getting Wild
Club Car
 
Join Date: Jan 2010
Location: Central MS
Posts: 98
Default Charger Doesn't Cycle

Hey Guys - Looking at a cart and the charger doesn't cycle like it should when plugged in. Cart has new batteries, and the OBC does kick the charger on after being plugged in for about 7-10 seconds. But it doesn't kick off then back on again like it is supposed to before it begins its charging cycle. I thought it may be the OBC, but the delay is there and it wouldn't be if the OBC was not working, would it?. We tried two chargers and they both did the same thing. Any suggestions?

Brian
bdmonist is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 03-26-2010, 05:47 PM   #2
Gone Wild
 
Fishing Dude's Avatar
Club Car
 
Join Date: Jul 2008
Location: Slums of Lake Erie
Posts: 3,722
Default Re: Charger Doesn't Cycle

Yes it could be bad. There are things need to know, voltage (36, 4, year, how old are batteries?
Fishing Dude is offline   Reply With Quote
Unread 03-26-2010, 10:57 PM   #3
Getting Wild
Club Car
 
Join Date: Jan 2010
Location: Central MS
Posts: 98
Default Re: Charger Doesn't Cycle

It's an 02 regen, non IQ, batts are 3mo old. 48 volt. What else could it be?
bdmonist is offline   Reply With Quote
Unread 03-26-2010, 11:13 PM   #4
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,093
Default Re: Charger Doesn't Cycle

2 chargers that work properly on other carts? Got to be a bad obc, not sampling the pack before beginning of charge cycle
scottyb is offline   Reply With Quote
Unread 03-26-2010, 11:36 PM   #5
Getting Wild
Club Car
 
Join Date: Jan 2010
Location: Central MS
Posts: 98
Default Re: Charger Doesn't Cycle

What is physically happening when the charger cuts off then back on again? I know the OBC is what causes the initial delay, so I was leaning to something else????
bdmonist is offline   Reply With Quote
Unread 03-31-2010, 08:15 AM   #6
Getting Wild
 
ajbrown's Avatar
Club Car
 
Join Date: Dec 2009
Location: The Villages, FL
Posts: 144
Default Re: Charger Doesn't Cycle

I put this out there just in case as it just happened to me. I moved the controller, OBC and solenoid to a new location and DOH put the OBC in facing the wrong direction......

Had the exact same symptoms....
ajbrown is offline   Reply With Quote
Unread 03-31-2010, 12:18 PM   #7
Gone Wild
 
Fishing Dude's Avatar
Club Car
 
Join Date: Jul 2008
Location: Slums of Lake Erie
Posts: 3,722
Default Re: Charger Doesn't Cycle

Quote:
Originally Posted by ajbrown View Post
I put this out there just in case as it just happened to me. I moved the controller, OBC and solenoid to a new location and DOH put the OBC in facing the wrong direction......

Had the exact same symptoms....
Thought that myself
Fishing Dude is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
1989 EZ GO 2 cycle Gas Gas EZGO
Which 2 cycle oil Gas EZGO
converting an old style dial charger to a smart charger for Marathon Electric EZGO
G1 2 cycle need help Gas Yamaha
88 ez go 2 cycle Gas EZGO


All times are GMT -5. The time now is 05:55 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.