lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 03-27-2010, 01:18 PM   #1
Not Yet Wild
Club Car
 
Join Date: Mar 2010
Location: Mississippi
Posts: 17
Question motor slipping, 05 precedent

I have an 05 precedent electric... it seams like the motor is slipping when I press the pedal. Can someone give me some insight on what this could be?
1ramey is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 03-27-2010, 04:18 PM   #2
Fry's Golf Carts
 
yamahag9er's Avatar
Club Car
 
Join Date: Dec 2006
Location: Central Michigan
Posts: 834
Default Re: motor slipping, 05 precedent

Are there any noises being made? Any more info other than it seems like it is slipping? How does the cart run other than that?
yamahag9er is offline   Reply With Quote
Unread 03-27-2010, 04:52 PM   #3
Not Yet Wild
Club Car
 
Join Date: Mar 2010
Location: Mississippi
Posts: 17
Default Re: motor slipping, 05 precedent

I have only had it for a week and it seams to have been fine up until today and its just kinda jumps or slips when you start off or when you first push the pedal. Don't really have any noise or anything. Also, notice today that it seams like its not as fast one time to the next when you get on it.
1ramey is offline   Reply With Quote
Unread 03-27-2010, 07:29 PM   #4
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 8,002
Default Re: motor slipping, 05 precedent

Quote:
Originally Posted by 1ramey View Post
I have only had it for a week and it seams to have been fine up until today and its just kinda jumps or slips when you start off or when you first push the pedal. Don't really have any noise or anything. Also, notice today that it seams like its not as fast one time to the next when you get on it.
"Jump" gives me more information than "slip"..... Take off the motor. If it smells like rotten eggs toss it and put in another one.
TahoeDawgZ71 is offline   Reply With Quote
Unread 03-27-2010, 07:39 PM   #5
Ban Puppy Mills & Stores!
 
scubabud's Avatar
Club Car
 
Join Date: Dec 2008
Location: SE Florida
Posts: 2,945
Default Re: motor slipping, 05 precedent

Quote:
Originally Posted by TahoeDawgZ71 View Post
"Jump" gives me more information than "slip"..... Take off the motor. If it smells like rotten eggs toss it and put in another one.
You might want to toss it to a re-builder like PQ or EMP to upgrade from a stock motor to a performance one. $225 with core plus shipping from PQ.
scubabud is offline   Reply With Quote
Unread 03-27-2010, 10:24 PM   #6
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 8,002
Default Re: motor slipping, 05 precedent

Quote:
Originally Posted by scubabud View Post
You might want to toss it to a re-builder like PQ or EMP to upgrade from a stock motor to a performance one. $225 with core plus shipping from PQ.
I'll second that.
TahoeDawgZ71 is offline   Reply With Quote
Unread 03-27-2010, 10:51 PM   #7
Gone Wild
 
golfcarfixer's Avatar
Club Car
 
Join Date: Sep 2009
Location: DELAWARE
Posts: 2,656
Default Re: motor slipping, 05 precedent

I looked at your post yesterday and wasnt sure what you were talking about.It sure seems like you might have a bad battery.you might want to check them,one might be weak.
golfcarfixer is offline   Reply With Quote
Unread 03-28-2010, 06:58 AM   #8
Not Yet Wild
 
samsonone's Avatar
Club Car
 
Join Date: Mar 2010
Location: jacksonville Fl.
Posts: 49
Default Re: motor slipping, 05 precedent

if it is shuttering when you press the accel. low battery voltage either a bad battery or not fully charged check both
samsonone is offline   Reply With Quote
Unread 03-28-2010, 08:09 AM   #9
Fry's Golf Carts
 
yamahag9er's Avatar
Club Car
 
Join Date: Dec 2006
Location: Central Michigan
Posts: 834
Default Re: motor slipping, 05 precedent

Quote:
Originally Posted by samsonone View Post
if it is shuttering when you press the accel. low battery voltage either a bad battery or not fully charged check both
Yup. Definately check your batteries. That's not to say it couldn't be a motor problem, but check the batts first.
yamahag9er is offline   Reply With Quote
Unread 03-28-2010, 08:52 AM   #10
Gone Wild
 
Join Date: Feb 2009
Location: Not sure yet
Posts: 500
Default Re: motor slipping, 05 precedent

Its a battery issue, every time I hear the "rearend is slipping" or "the motor is slipping" it is usually is bad batteries.
FIXEROFCARTS is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
precedent motor speed sensor Electric Club Car
Precedent Motor Electric Club Car
Help with Precedent Motor install Electric Club Car
Precedent Motor Replacement Electric Club Car
Precedent motor stuck Electric Club Car


All times are GMT -5. The time now is 06:51 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.