lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 04-04-2010, 10:52 AM   #1
Not Yet Wild
 
Join Date: May 2009
Posts: 2
Default 2005 club car clicks but wont go

solenoid clicks and car attempts to move but solenoid clicks again and no movement
deweford is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 04-04-2010, 12:11 PM   #2
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,081
Default Re: 2005 club car clicks but wont go

Welcome to BGW !!!

What is the pack voltage reading? Do you have a digital Voltmeter? You will need one to do any diagnostics....
scottyb is online now   Reply With Quote
Unread 04-06-2010, 09:44 PM   #3
Not Yet Wild
 
Join Date: May 2009
Posts: 2
Default Re: 2005 club car clicks but wont go

sunday afternoon quit completely. monday, wife took it for a spin and it worked great. go figure?
deweford is offline   Reply With Quote
Unread 04-07-2010, 09:46 AM   #4
Not Yet Wild
 
Join Date: Feb 2010
Posts: 15
Default Re: 2005 club car clicks but wont go

I have a 2005 ds club car that will runs normal for about 10 feet then looses power, still runs but no power. New 8-volt trojans, i checked battery voltage at the charger receptacle and it reads 50 volts till loss of power then drops down to 36-37 volts. I'm thinking it's the motor speed sensor or the mcor can you let me know what ya'll think and give me some troubleshoot tips. Thanks
mwillis is offline   Reply With Quote
Unread 04-07-2010, 09:50 AM   #5
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,081
Default Re: 2005 club car clicks but wont go

A voltage drop like means batteries or cable connections? Did you put new cables on with the new batteries? If not you should.
scottyb is online now   Reply With Quote
Unread 04-07-2010, 10:11 AM   #6
Not Yet Wild
 
Join Date: Feb 2010
Posts: 15
Default Re: 2005 club car clicks but wont go

I did put new 4 gauge wire with the new batteries, if i turn the cart to tow and then back to run it will run normal but not for very long? Thanks
mwillis is offline   Reply With Quote
Unread 04-07-2010, 10:26 AM   #7
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,081
Default Re: 2005 club car clicks but wont go

That is weird! Maybe somebody will know what that means?
scottyb is online now   Reply With Quote
Unread 04-11-2010, 11:20 AM   #8
Not Yet Wild
 
Join Date: Jul 2008
Location: Michigan
Posts: 21
Default Re: 2005 club car clicks but wont go

I am the mechanic at a golf course with 60 2002 Club Car electric carts. I had a problem somewhat like this last summer. Cart would take off just fine, travel a short distance, then shut down. Release the throttle pedal, then press it down again, the cart would go again for a short distance. I tried changing both the MCOR and the Motor Controller with no success. I keep an extra on the shelf. I then realized that the person who replaced the batteries with new ones, hadn't tightened the new battery cables tight enough. He had also used spray-on connector protection which actually created a worst connection because of the loose battery nuts in the first place. I retightened the battery nuts and everything worked fine. I then gave the cart guy an inch pounds torque wrench to use to properly tighten the battery connections to the spec Club Car recommends in the owners manual. I believe it was 45 to 50 inch pounds.
Dinger is offline   Reply With Quote
Unread 04-17-2010, 09:55 AM   #9
Not Yet Wild
 
Join Date: Feb 2010
Posts: 15
Default Re: 2005 club car clicks but wont go

I replaced the tach sensor/speed sensor on my 05 Club Car and this fixed the problem. Thanks for the replies.
mwillis is offline   Reply With Quote
Unread 04-17-2010, 11:23 PM   #10
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 8,015
Default Re: 2005 club car clicks but wont go

Quote:
Originally Posted by mwillis View Post
I replaced the tach sensor/speed sensor on my 05 Club Car and this fixed the problem. Thanks for the replies.
Glad it worked for you.... But the speed sensor won't cause a voltage drop. Keep an eye on that.
TahoeDawgZ71 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
2005 g22 yamaha wont go? solenoid turns off Electric Yamaha
1996 txt clicks but wont go Electric EZGO
95Carryall just clicks,wont move Electric Club Car
solenoid clicks/ wont move Electric EZGO
club car clicks but wont go Electric Club Car


All times are GMT -5. The time now is 09:22 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.