lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 04-16-2010, 03:32 PM   #1
Not Yet Wild
Club Car
 
Join Date: Aug 2009
Location: Western New York
Posts: 21
Question new trojans / cables and very slow

96 DS

cart did move slow before but batteries were shot. Replaced all new 8V trojens, new batt cables and cleaned sonoid connections. Charger looks to be working fine and there is 52.4V accross the pack.

PROBLEM: very slow forward and reverse is all but , what do and how to check next?

thanks
scobar is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 04-19-2010, 09:23 AM   #2
Not Yet Wild
Club Car
 
Join Date: Aug 2009
Location: Western New York
Posts: 21
Default Re: new trojans / cables and very slow

bump
scobar is offline   Reply With Quote
Unread 04-19-2010, 09:37 AM   #3
Not Yet Wild
Club Car
 
Join Date: Apr 2010
Location: Freedom, NH
Posts: 15
Default Re: new trojans / cables and very slow

Had you clocked the speed (with a GPS or aside a car) prior to the new batteries? Is the speed the same as with the old batteries? Can you define "slow" (5, 10, 15 MPH)? Could be the speed control unit - have you tried to bypass and connect 48 volts straight to motor and see if motor runs faster (with rear wheels jacked up)? I'm no expert, but that's what I'd try next...
Notch is offline   Reply With Quote
Unread 04-19-2010, 09:40 AM   #4
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,053
Default Re: new trojans / cables and very slow

Are you sure you have ALL of the batteries wired into the pack and the cart is connected to ALL 6 batteries in series?
Double check ........ Sometimes only 5 are connected to the cart???

New batteries are only at about 75% capacity until properly broke-in.
scottyb is offline   Reply With Quote
Unread 04-19-2010, 09:42 AM   #5
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,053
Default Re: new trojans / cables and very slow

A 96 CC is not a fast cart by design..... how slow is slow?
scottyb is offline   Reply With Quote
Unread 04-20-2010, 07:32 PM   #6
Not Yet Wild
Club Car
 
Join Date: Aug 2009
Location: Western New York
Posts: 21
Default Re: new trojans / cables and very slow

Quote:
Originally Posted by Notch View Post
Had you clocked the speed (with a GPS or aside a car) prior to the new batteries? Is the speed the same as with the old batteries? Can you define "slow" (5, 10, 15 MPH)? Could be the speed control unit - have you tried to bypass and connect 48 volts straight to motor and see if motor runs faster (with rear wheels jacked up)? I'm no expert, but that's what I'd try next...
I can walk faster than the cart can go. Not sure how to hook 48V direct to the motor, I don't want to put 48 on the wrong post of the motor and create more problems.
scobar is offline   Reply With Quote
Unread 04-20-2010, 07:37 PM   #7
Not Yet Wild
Club Car
 
Join Date: Aug 2009
Location: Western New York
Posts: 21
Default Re: new trojans / cables and very slow

Quote:
Originally Posted by scottyb View Post
Are you sure you have ALL of the batteries wired into the pack and the cart is connected to ALL 6 batteries in series?
Double check ........ Sometimes only 5 are connected to the cart???

New batteries are only at about 75% capacity until properly broke-in.
All 6 bats are in series with all new cables between them, like I mentioned I can walk faster and in reverese it won't hardly move at all. Across the pack is 52.4 or something close to that. I put a load tester on each batt and they ck OK. They are trojans 860.

Does that sound like like a break in?? stumped on waht to do next but I do like the idea of 48 right to the motor. I'm not near the cart but I do believe there are 2 wires to the motor, will 48 on one podt go forward and 48 on the other go in reverse?
thanks
scobar is offline   Reply With Quote
Unread 04-23-2010, 11:41 AM   #8
Not Yet Wild
Club Car
 
Join Date: Aug 2009
Location: Western New York
Posts: 21
Default Re: new trojans / cables and very slow

bump
scobar is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
gc8 sams club batteries vs trojans t875 Electric Club Car
1/0 Battery Cables to 6 AWG Motor Cables Electric EZGO
what will changing my cables to 4g welding cables do to my performance exactly Electric EZGO
Good price for Trojans Electric EZGO
Year of Trojans Electric Club Car


All times are GMT -5. The time now is 09:35 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.