lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 04-26-2010, 08:05 PM   #1
Not Yet Wild
Club Car
 
Join Date: Apr 2010
Location: coalmont,tn.
Posts: 4
Question 2005 precedent wont do anything.....

i had a problem with slow speed,a cludcar tech. told me it was the speed sensor on the motor.itook it off,looked at it,cleaned it up,put it back on and now it won't do anything..key on,tow switch in "run"position,batt. reading 51v. backup alarm or anything else won't work..what have i done?
groovie1955 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 04-26-2010, 08:30 PM   #2
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 7,981
Default Re: 2005 precedent wont do anything.....

Quote:
Originally Posted by groovie1955 View Post
i had a problem with slow speed,a cludcar tech. told me it was the speed sensor on the motor.itook it off,looked at it,cleaned it up,put it back on and now it won't do anything..key on,tow switch in "run"position,batt. reading 51v. backup alarm or anything else won't work..what have i done?
Hopefully you didn't arc two posts of the motor together with a wrench when you were back there. Think that may have happened?
TahoeDawgZ71 is offline   Reply With Quote
Unread 04-26-2010, 08:33 PM   #3
Not Yet Wild
Club Car
 
Join Date: Apr 2010
Location: coalmont,tn.
Posts: 4
Default Re: 2005 precedent wont do anything.....

no.. had batt. disconnected...
groovie1955 is offline   Reply With Quote
Unread 04-26-2010, 09:28 PM   #4
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 7,981
Default Re: 2005 precedent wont do anything.....

Quote:
Originally Posted by groovie1955 View Post
no.. had batt. disconnected...
Hmmm... Did you have it in the TOW position when you worked on it? Even though the batteries were disconnected, the controller still stores enough power in it's capacitors to create an arc big enough to fry some components.... Tampering with the speed sensor itself should have no direct effect on the car as far as whether it'll run or not. It'll make it run slow, but definitely won't keep it from running altogether.
TahoeDawgZ71 is offline   Reply With Quote
Unread 04-26-2010, 10:41 PM   #5
Ban Puppy Mills & Stores!
 
scubabud's Avatar
Club Car
 
Join Date: Dec 2008
Location: SE Florida
Posts: 2,945
Default Re: 2005 precedent wont do anything.....

Quote:
Originally Posted by groovie1955 View Post
i had a problem with slow speed,a cludcar tech. told me it was the speed sensor on the motor.itook it off,looked at it,cleaned it up,put it back on and now it won't do anything..key on,tow switch in "run"position,batt. reading 51v. backup alarm or anything else won't work..what have i done?
Did you check the fuses under the plastic cover between the batteries I think that something did get touched by accident causing something to go. Should be the one with a black plastic cap and red leads but don't remember off the top of my head for sure.
scubabud is offline   Reply With Quote
Unread 04-27-2010, 12:41 PM   #6
Not Yet Wild
Club Car
 
Join Date: Apr 2010
Location: coalmont,tn.
Posts: 4
Smile Re: 2005 precedent wont do anything.....

cleared computer and everything works ..thanks for the help....
groovie1955 is offline   Reply With Quote
Unread 04-27-2010, 06:39 PM   #7
Gone Wild
 
PLUMQUICK's Avatar
 
Join Date: Feb 2009
Posts: 487
Default Re: 2005 precedent wont do anything.....

TahoeDawgZ71, I must say you are a GREAT tech and to see you help so many people............people like you are what makes this site so GREAT.................keep up the OUTSTANDING work.....
PLUMQUICK is offline   Reply With Quote
Unread 04-27-2010, 08:11 PM   #8
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 7,981
Default Re: 2005 precedent wont do anything.....

Quote:
Originally Posted by PLUMQUICK View Post
TahoeDawgZ71, I must say you are a GREAT tech and to see you help so many people............people like you are what makes this site so GREAT.................keep up the OUTSTANDING work.....
Thanks.. I actually enjoy it a lot... I called you guys a few weeks ago and spoke with Robby. I'm really impressed with what you guys are doing. I'm trying to plan a trip up there to watch some drag racing.
TahoeDawgZ71 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
2005 club car clicks but wont go Electric Club Car
2005 Precedent wiring help Electric Club Car
2005 Precedent issues... Electric Club Car
2005 Precedent advice Electric Club Car
2005 CC Precedent Members Rides


All times are GMT -5. The time now is 03:30 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.