lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 04-27-2010, 10:40 PM   #11
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 8,025
Default Re: HELP me with Charging Issue!

Quote:
Originally Posted by indacup View Post
But don't ya think two different chargers being bad would be close to impossible?
Yes.. I agree it's very unlikely. What's the battery voltage of the entire pack when the charger turns off? What's the ammeter reading?
TahoeDawgZ71 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 04-27-2010, 10:48 PM   #12
Not Yet Wild
Tomberlin
 
Join Date: Jul 2009
Location: Iowa
Posts: 39
Default Re: HELP me with Charging Issue!

Quote:
Originally Posted by TahoeDawgZ71 View Post
".... What's the battery voltage of the entire pack when the charger turns off? What's the ammeter reading?
Unfortunately, I never got those readings......The place I took the cart to, told me all looked fine....I WISH I woulda asked....

I cannot drive another 4 hours round trip to the place I bought the cart from...so I guess I will have to call a couple local firms to help me....and see if they can either drop by the cart shed and fix...or pick up.

I have no clue...
indacup is offline   Reply With Quote
Unread 04-27-2010, 10:50 PM   #13
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 8,025
Default Re: HELP me with Charging Issue!

Quote:
Originally Posted by indacup View Post
Unfortunately, I never got those readings......The place I took the cart to, told me all looked fine....I WISH I woulda asked....

I cannot drive another 4 hours round trip to the place I bought the cart from...so I guess I will have to call a couple local firms to help me....and see if they can either drop by the cart shed and fix...or pick up.

I have no clue...
Well that's why we're all here... To keep you from having to do that.. Do you have a multimeter you can use to check voltage? Give me that information I mentioned above and I'll be glad to tell you the next step.
TahoeDawgZ71 is offline   Reply With Quote
Unread 04-27-2010, 10:58 PM   #14
Not Yet Wild
Tomberlin
 
Join Date: Jul 2009
Location: Iowa
Posts: 39
Default Re: HELP me with Charging Issue!

Quote:
Originally Posted by TahoeDawgZ71 View Post
Well that's why we're all here... To keep you from having to do that.. Do you have a multimeter you can use to check voltage? Give me that information I mentioned above and I'll be glad to tell you the next step.
I have no multimeter...

I really, REALLY appreciate your kind offers...but I have accepted the fact that I am gonna get screwed on this.
indacup is offline   Reply With Quote
Unread 04-27-2010, 11:47 PM   #15
Ban Puppy Mills & Stores!
 
scubabud's Avatar
Club Car
 
Join Date: Dec 2008
Location: SE Florida
Posts: 2,945
Default Re: HELP me with Charging Issue!

Quote:
Originally Posted by indacup View Post
I have no multimeter...

I really, REALLY appreciate your kind offers...but I have accepted the fact that I am gonna get screwed on this.
Let us know what it is then and what it cost ya...
scubabud is offline   Reply With Quote
Unread 04-28-2010, 12:26 PM   #16
Not Yet Wild
Tomberlin
 
Join Date: Jul 2009
Location: Iowa
Posts: 39
Default Re: HELP me with Charging Issue!

Quote:
Originally Posted by keg View Post
just a wild card, Ijust went thru a elec. mess on mine
Did you replace your main ground ? if so make sure you went thru the obc not around. turns out the obc knows if the cable is going thru. My charger would tun on then off 2 times. After I re-did the ground its been fine
This may be the culprit...I talked to the guy who painted the cart and he said he removed the cable and not sure how he re-hooked it up.
indacup is offline   Reply With Quote
Unread 04-28-2010, 01:54 PM   #17
Gone Wild
 
golfcarfixer's Avatar
Club Car
 
Join Date: Sep 2009
Location: DELAWARE
Posts: 2,656
Default Re: HELP me with Charging Issue!

Sounds like an easy fix just go and take a gander at it.
golfcarfixer is offline   Reply With Quote
Unread 04-28-2010, 04:57 PM   #18
Ban Puppy Mills & Stores!
 
scubabud's Avatar
Club Car
 
Join Date: Dec 2008
Location: SE Florida
Posts: 2,945
Default Re: HELP me with Charging Issue!

Quote:
Originally Posted by indacup View Post
This may be the culprit...I talked to the guy who painted the cart and he said he removed the cable and not sure how he re-hooked it up.
If he removed the cable from the battery would be different then removing it from the OBC. He would have purposely cut one end off that cable, pull it out of the OBC, then crimp an end back on the cable and place it back on the battery.
Now if the wires were changed out completely for an upgrade or just new wires... that would make sense!

As GCF stated... simply look to see if it's there or not...
scubabud is offline   Reply With Quote
Unread 04-30-2010, 06:56 AM   #19
Not Yet Wild
Tomberlin
 
Join Date: Jul 2009
Location: Iowa
Posts: 39
Default Re: HELP me with Charging Issue! - Problem Fixed!

Turns out...after a long diagnostic at a local facility, there was NOTHING wrong with the cart...it was the Cart...SHED!

Apparently at my cart shed, there was some sort of voltage feed inconsistency, and from what I was told, the computer reads that and as a safeguard (in case of lightning strike or some other surge), shuts everything down when it registers that.

We moved the cart into a temporary shed and it charged up...no problem.

In the process, I also learned that before, I'd turn on the charger...it would turn on for 2 minutes and shut off...with a GOOD connection, the charger will turn on for 10 seconds, temporarily shut off for about two, then back on to charge...that quick "on/off" is for it to read and assure all connections are good.

Anyway, it's all fine...drove 18+ holes last nite!


Thanks everone for your input...you are good people!
indacup is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Par car charging issue. Gas Columbia ParCar
Charging issue..... Electric EZGO
charging/power issue Electric Club Car
Another battery charging issue Electric Club Car
Charging Issue 99 Club Car DS Electric Club Car


All times are GMT -5. The time now is 01:09 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.