lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 04-28-2010, 11:16 PM   #1
Not Yet Wild
 
Join Date: Apr 2010
Posts: 7
Default Cart moves slow then nothing

I am new here and to golf carts. My Club Cart is a 2001 48v 6-8v batteries. Cables are clean and good. Terminals have all been cleaned. All batteries test between 8-9 volts. Charged batteries over night and charger was not off after over night charging. I step on the pedal real lightly to make it go and then push a tad further and it stops. No go when pedal is pushed all the way down. It sounds like the solenoid clicks out when I push the pedal past about 1/4 way down. Anyone have any ideas what is not happening here??
Thanks,
Jim
r2d2jim is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 04-29-2010, 06:41 PM   #2
Gone Wild
 
Gorhad's Avatar
Club Car
 
Join Date: Jan 2010
Location: Brevard County, Florida
Posts: 214
Default Re: Cart moves slow then nothing

Is there a shudder you you push the pedal further?
Gorhad is offline   Reply With Quote
Unread 04-29-2010, 06:46 PM   #3
Gone Wild
 
goofymaz's Avatar
 
Join Date: Mar 2010
Posts: 237
Default Re: Cart moves slow then nothing

huh? anyone else get that?
goofymaz is offline   Reply With Quote
Unread 04-29-2010, 09:39 PM   #4
Not Yet Wild
 
Join Date: Apr 2010
Posts: 7
Default Re: Cart moves slow then nothing

No shudder. I press the pedal down and I hear a "click" and the cart starts to move real slow. So I press down a little further to increase the speed and I hear a "click' and the cart stops moving. I can continue to press the pedal all the way to the floor and nothing happens. It does this in forward and in reverse.

I think it is the solenoid kicking in then out when you press further on the pedal.
r2d2jim is offline   Reply With Quote
Unread 04-30-2010, 07:48 PM   #5
Gone Wild
 
goofymaz's Avatar
 
Join Date: Mar 2010
Posts: 237
Default Re: Cart moves slow then nothing

yes it is! when you put the cart in reverse is the beeper sounding?
goofymaz is offline   Reply With Quote
Unread 05-02-2010, 07:27 PM   #6
Not Yet Wild
 
Join Date: Apr 2010
Posts: 7
Default Re: Cart moves slow then nothing

Yes, the beeper sounds nice and loud!!
r2d2jim is offline   Reply With Quote
Unread 05-17-2010, 10:51 AM   #7
Not Yet Wild
 
Join Date: Apr 2010
Posts: 7
Default Re: Cart moves slow then nothing

Guys,
If anyone has some ideas that may help I really want to hear from you. I want to get this cart working soon. I checked the total battery voltage where it leaves the last battery and it was 48 volts. Can I then assume then that the batteries are ok?
r2d2jim is offline   Reply With Quote
Unread 05-17-2010, 10:57 AM   #8
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,060
Default Re: Cart moves slow then nothing

48v is below 50% capacity. A point considered empty. THat is not a good sign for the batteries after charging. Likely you need to load test or check Specific Gravity of each battery ( S/G of each Cell) to determine if in fact the batteries are GOOD. One or more may read voltage but drop out under load..... Once you establish good batteries you can proceed to what may be throttle linkage issues? But check the batts first
scottyb is online now   Reply With Quote
Unread 05-17-2010, 10:58 AM   #9
Gone Wild
 
Gorhad's Avatar
Club Car
 
Join Date: Jan 2010
Location: Brevard County, Florida
Posts: 214
Default Re: Cart moves slow then nothing

If your batteries are at 48 volts as you say then they are only at around 45% charge, which is quite low.

How old are the batteries?
Gorhad is offline   Reply With Quote
Unread 05-17-2010, 10:59 AM   #10
Gone Wild
 
Gorhad's Avatar
Club Car
 
Join Date: Jan 2010
Location: Brevard County, Florida
Posts: 214
Default Re: Cart moves slow then nothing

Sorry Scotty must have been replying at same time
Gorhad is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Forward Reverse switch arcs, cart moves with key off Electric Club Car
Car moves, then dies... Electric Club Car
G1 moves while trying to start Gas Yamaha
'89 club car moves when key off??? Electric Club Car
Cart only moves at half throttle on 02 48 volt Electric Club Car


All times are GMT -5. The time now is 08:57 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.