lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 05-05-2010, 09:28 PM   #1
Not Yet Wild
 
Join Date: May 2010
Posts: 7
Default Cart stopped running and won't charge

Was driving cart (97 Club Car) then it suddenly quit moving. I checked for power from first battery to last and connection is good. Lights won't work, but turn signal indicator on steering column lights up barely when flashers are on but no lights will work. I tested the switch by checking the wire from switch to converter. Power to converter is turning off when switch turns off. Every connection I check is good. Every fuse I can find is good. I plugged in charger and charger will not come on. Any suggestions?
terparrot is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 05-05-2010, 11:49 PM   #2
Gone Wild
 
Fishing Dude's Avatar
Club Car
 
Join Date: Jul 2008
Location: Slums of Lake Erie
Posts: 3,722
Default Re: Cart stopped running and won't charge

Does the solenoids click?
Fishing Dude is offline   Reply With Quote
Unread 05-06-2010, 06:29 AM   #3
Not Yet Wild
 
Join Date: May 2010
Posts: 7
Default Re: Cart stopped running and won't charge

No...
I am getting nothing.
terparrot is offline   Reply With Quote
Unread 05-06-2010, 12:23 PM   #4
Gone Wild
 
Fishing Dude's Avatar
Club Car
 
Join Date: Jul 2008
Location: Slums of Lake Erie
Posts: 3,722
Default Re: Cart stopped running and won't charge

What's the voltage on each side (large terminals)? Then what is it on the small terminals.
Fishing Dude is offline   Reply With Quote
Unread 05-06-2010, 12:57 PM   #5
Not Yet Wild
 
Join Date: May 2010
Posts: 7
Default Re: Cart stopped running and won't charge

On the solenoid? With key on? Pedal down?
terparrot is offline   Reply With Quote
Unread 05-06-2010, 02:10 PM   #6
Gone Wild
 
Fishing Dude's Avatar
Club Car
 
Join Date: Jul 2008
Location: Slums of Lake Erie
Posts: 3,722
Default Re: Cart stopped running and won't charge

key on peddle up, and down.
Fishing Dude is offline   Reply With Quote
Unread 05-06-2010, 03:40 PM   #7
Not Yet Wild
 
Join Date: May 2010
Posts: 7
Default Re: Cart stopped running and won't charge

With pedal pushed, around 5 on big and 15 on little. I placed tester probes on both big ones, get nothing until pedal is pushed then get 5 when it is pushed. Similarly, both on small ones, get around 15 but jumpier on guage.
terparrot is offline   Reply With Quote
Unread 05-07-2010, 04:33 AM   #8
Gone Wild
 
Fishing Dude's Avatar
Club Car
 
Join Date: Jul 2008
Location: Slums of Lake Erie
Posts: 3,722
Default Re: Cart stopped running and won't charge

What's your battery pack read?
Fishing Dude is offline   Reply With Quote
Unread 05-07-2010, 08:40 PM   #9
Not Yet Wild
 
Join Date: May 2010
Posts: 7
Default Re: Cart stopped running and won't charge

All 6 batteries needed water. I put distilled water in all of them. The battery pack reads 48-50. When I push down pedal the cart starts jumping like it is really low on power. When pedal is pushed the pack drops to 25. I pulled all cables and checked each battery. The batteries are all at 8 except one is around 6. I cleaned all cables and connections, reconnected them all. Lights will work but dim. Low battery indicator comes on. I thought I was good now and merely needed a charge. When I plug in charger, nothing happens. Charger will not come on. I have checked fuse on charger and it looks good. All connections to where charger connects look good. All fuses look good. Anything else I can do?
terparrot is offline   Reply With Quote
Unread 05-07-2010, 10:47 PM   #10
Gone Wild
 
Fishing Dude's Avatar
Club Car
 
Join Date: Jul 2008
Location: Slums of Lake Erie
Posts: 3,722
Default Re: Cart stopped running and won't charge

ewset the circuit breaker,clean the female side of the plug may have rust in it.
Fishing Dude is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
1999 EZ GO stopped running Electric EZGO
Stopped running. Electric Yamaha
cart just stopped Electric Yamaha
keyed ignition to keep g9 running while stopped ?????? Gas Yamaha
2002 electric EZ GO Golf Cart Just stopped running Electric EZGO


All times are GMT -5. The time now is 06:05 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.