lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 05-11-2010, 10:46 AM   #1
Not Yet Wild
 
Join Date: May 2010
Posts: 4
Default dchelmondollar

I have a 2006 cc ds i put a 6" lift on it and my brake pettle gos all the all the way to the floor before you can stop it,the hill brake will not stay set,and the pettle will kick back at your foot before it will stop. They were fine befor the lift and bigger tires. Please ,Help wife is going crazy.
dchelmondollar is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 05-11-2010, 10:56 AM   #2
IDK&YDE
 
wilster734's Avatar
Club Car
 
Join Date: Jan 2010
Location: TEXAS
Posts: 771
Default Re: dchelmondollar

Either your adjustments are all out of whack or You need a drop bracket for the cables to be the same as stock before the lift.I would think the bracket is what you need if you did not mess with the adjustments when you put the lift on.
wilster734 is offline   Reply With Quote
Unread 05-11-2010, 10:58 AM   #3
IDK&YDE
 
wilster734's Avatar
Club Car
 
Join Date: Jan 2010
Location: TEXAS
Posts: 771
Default Re: dchelmondollar

Wait just reread what you said and you need to check to make sure your axle has not turned in the u-bolts. Then go with adjustments.somewhere there is a post about adjustments.
wilster734 is offline   Reply With Quote
Unread 05-11-2010, 11:05 AM   #4
Gone Wild
 
OLD MEC's Avatar
Club Car
 
Join Date: Mar 2009
Location: South Texas
Posts: 2,391
Default Re: dchelmondollar

Lets get the "BOSS" off your back. I know the routine "In spite of what I said you went ahead and spend all that money when it was just fine before and didnt need all those expensive parts" Sounds like you may have to readjust your brake cables as lifting changes the drop distance between frame and rear axle causes similar problems to what you talk about. If that doesn't work you may need to add a extension to brake cables ( SEE SPONSORS ) to solve problem. Also are you sure wheels are fitting correctly ( LUG NUTS into wheel depressions ) some wheels dont exactly fit bolt pattern and cause wheel twist?
OLD MEC is offline   Reply With Quote
Unread 05-11-2010, 12:23 PM   #5
Not Yet Wild
 
Join Date: May 2010
Posts: 4
Default Re: dchelmondollar

Thanks, I with try this .If I need the extensions were on line can i get them
dchelmondollar is offline   Reply With Quote
Unread 05-11-2010, 12:29 PM   #6
IDK&YDE
 
wilster734's Avatar
Club Car
 
Join Date: Jan 2010
Location: TEXAS
Posts: 771
Default Re: dchelmondollar

check with site sponsors
wilster734 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes



All times are GMT -5. The time now is 05:26 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.