lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 05-23-2010, 02:27 PM   #1
Not Yet Wild
Club Car
 
Join Date: Jan 2010
Location: Charleston, SC
Posts: 66
Default Tie rod ends not taking grease

I recently installed new tie rod ends on my cart (purchased from the CC dealer), but they won't accept any grease from my grease gun. I already removed the fittings to make sure they are not stuck. Any ideas??
Loosewire is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 05-23-2010, 05:34 PM   #2
Gone Wild
 
OLD MEC's Avatar
Club Car
 
Join Date: Mar 2009
Location: South Texas
Posts: 2,391
Default Re: Tie rod ends not taking grease

This is quite common with NEW tie rod ends on golf carts? I dont know why they are so tight when new but? I find that you need a compound high pressure grease gun or an air powered gun until they break in. I am using a Grainger #4BY72 10000 Lbs pressure gun that has a hard time with new tie rods. Tractor Supply has a good one that nehibor is using #3951137.
Hopefully you wont need to grease them for quite awhile after installation as they should be full when built? I know I always want to fill them after installing too??
OLD MEC is offline   Reply With Quote
Unread 05-24-2010, 09:39 AM   #3
Not Yet Wild
Club Car
 
Join Date: Jan 2010
Location: Charleston, SC
Posts: 66
Default Re: Tie rod ends not taking grease

Thanks OLD MEC, I will wait to try to put some grease in after 6 months or so. I think my neighbor has a high pressure grease gun I can use when the time comes.
Loosewire is offline   Reply With Quote
Unread 05-24-2010, 10:46 AM   #4
Gone Wild
 
OLD MEC's Avatar
Club Car
 
Join Date: Mar 2009
Location: South Texas
Posts: 2,391
Default Re: Tie rod ends not taking grease

When lubing new joints always flex joint from side to side to help getting grease through.
OLD MEC is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
tie rod ends Electric EZGO
rod ends Lifted Golf Carts
What grease to use Lifted Golf Carts
Do the tie rod ends need replacing? Gas Yamaha
g16 grease fittings??? Gas Yamaha


All times are GMT -5. The time now is 06:29 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.