lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
 
Thread Tools Search this Thread Display Modes
Old 06-06-2010, 06:57 PM   #1
Not Yet Wild
 
Join Date: Jan 2009
Posts: 28
Default 36 Volt Charger Hums but doesnt charge

I have a 92 CC 36 volt DS cart. I had a set of 6 volt AGM batteries (taken out of a RV I sold). I have installed 4 gauge cables on the cart. I noticed the cart not going as far on a charge. When I put the cart on the charger, the charger would click then hum and get warm. So I thought I was having battery issues. I put a good set of lead acid batteries in the cart (1 year old batteries) and when I plugged in the charger I suspected that the charger wasn't working. When plugged into the cart, the charger clicks, hums and gets warm. But the amp meter stays on the first mark 10 amps and never moves. I've been reading all of the threads I could find on 36 volt chargers. Here is of items I have checked...
1. Relay; I replaced but the new one clicks just like the old one did.
2. Amp Meter; I checked the meter using my 12 volt charger and putting the amp meter in series and It was working.
3. I removed the heat sink and checked the diodes... I was able to get a reading only in 1 direction. I cleaned the heat sink goop, then had to order some to re install the heat sink.
4. I checked the fuse with an Ohm meter and get 0.00. It is not open.
5. It has a 2" x 3" x 1" black box with an electronic circuit board... I do not have a clue how to test it.
6. It has a capaciter...I do not know how to test it.

What is the next step for testing/repairing the charger?

Note; I have used a 12 volt charger and charged the lead acid batteries (2 at a time) to a total of 37.7 volts (for the 6 pack). When I plug in the 36 volt charger and put a volt meter across the pack the voltage doesn't change after several hours. My next test is to run the cart awhile and put the 36 volt charger back on (to see if my batteries are currently at a full charge).
Thanks for all of the advice I get from this forum
ATV-RVr
ATV-RVr is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 06-06-2010, 11:15 PM   #2
Not Yet Wild
Club Car
 
Join Date: May 2010
Posts: 8
Default Re: 36 Volt Charger Hums but doesnt charge

Sounds like your charger is going out like mine did last week. You might want to check the capacitor in your charger or check the transformer. In my case, the transformer went out completely.

Rex
rexster is offline   Reply With Quote
Old 06-07-2010, 09:21 AM   #3
Not Yet Wild
 
Join Date: Jan 2009
Posts: 28
Default Re: 36 Volt Charger Hums but doesnt charge

Thanks Rexter for the reply.
I found this PDF and I wanted to post this link http://www.lesterelectrical.com/serv...otingguide.pdf
It is a trouble shooting guide for the 36 volt Lester Charger. It is a very detailed guide. Hopefully it will help others. It has a procedure for testing the capacitor that I'm going to go try. I will post what I find out on my charger situation.

ATV-RVr
ATV-RVr is offline   Reply With Quote
Old 06-07-2010, 04:22 PM   #4
Not Yet Wild
 
Join Date: Jan 2009
Posts: 28
Default Re: 36 Volt Charger Hums but doesnt charge

Update... I printed out the PDF file and did the capacitor test. It tested shorted. Once I removed the capacitor I realized how puffed out the sides were. I replaced it and when I hooked up the charger, The output amps jumped to 25 then after about 30 min the amps dropped to 15. Then I just checked it after 2 hours and the amps have dropped to 5. I will leave the charger plugged in over night then check it.
ATV-RVr is offline   Reply With Quote
Old 06-07-2010, 05:33 PM   #5
Gone Wild
 
DOOmsman's Avatar
Yamaha
 
Join Date: Jul 2008
Location: Reddick IL
Posts: 10,726
Default Re: 36 Volt Charger Hums but doesnt charge

Just in time to enjoy a cold fuzzy gold drink'
Isn't it great to fix something yourself.
DOOmsman is offline   Reply With Quote
Old 06-07-2010, 07:41 PM   #6
Not Yet Wild
Club Car
 
Join Date: May 2010
Posts: 8
Default Re: 36 Volt Charger Hums but doesnt charge

Hate to tell you; it's doing the same thing as my Lestronic. Even as far as the amp drop. Turned out the transformer had gone bad. 431$ later everything works great.

Rex
rexster is offline   Reply With Quote
Old 06-08-2010, 09:23 AM   #7
Not Yet Wild
 
Join Date: Jan 2009
Posts: 28
Default Re: 36 Volt Charger Hums but doesnt charge

After overnight charging the charger had shut down and the batteries showed full charge. I wrote down the number but can't find it...(will post it later). Today I will have the fun job of driving the cart around the hood. Then test the charger again. I will have to watch the weather...been raining here in Houston. I'm also working on a 05 CC DS project but that isn't on this post...
ATV-RVr is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Forum
EZGO Textron 36 Volt Battery Charger will not charge Electric EZGO
48 volt charger will not charge Electric Club Car
94 ezgo charger hums but doesn't charge Electric EZGO
48v charger hums but amps read 0 Electric Club Car
ezgo 36 volt charger min volt for charge? Electric golf carts


All times are GMT -5. The time now is 10:35 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.