lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 06-17-2010, 06:03 PM   #21
Not Yet Wild
Club Car
 
Join Date: Jun 2010
Location: Union Hall, VA
Posts: 43
Default Re: 94 club car quit working

I am having the exact same problem. Was running perfect then suddenly nothing but a click when I press on the pedal (batteries are new). I have one exception.....the solenoid is very hot to the touch. I had driven the cart for only 5 minutes or less. Could this be an additional indicator that the solenoid has gone bad? I am new to cart ownership so just learning.
jcow is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 06-17-2010, 07:01 PM   #22
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: 94 club car quit working

try jumping the large post on solenoid and see if cart runs..........if so replace it................................................ ...
shadowman is offline   Reply With Quote
Unread 06-19-2010, 04:46 AM   #23
Not Yet Wild
Club Car
 
Join Date: Jun 2010
Location: Union Hall, VA
Posts: 43
Default Re: 94 club car quit working

Thanks............ 10 minutes after posting my issue it started running again. Seems to be normal now. Go figure.
jcow is offline   Reply With Quote
Unread 06-19-2010, 09:10 PM   #24
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: 94 club car quit working

it could be a solenoid going bad so if it quits again try jumping it......................
shadowman is offline   Reply With Quote
Unread 06-25-2010, 08:06 PM   #25
Not Yet Wild
Club Car
 
Join Date: Jun 2010
Location: Union Hall, VA
Posts: 43
Default Re: 94 club car quit working

You were correct. It is still running but this evening I noticed the smell of burning wires. It was the white one coming from the solenoid which was too hot to touch. In fact the post it is bolted to is actually coming loose from the solenoid (can wiggle it with my finger).

Really appreciate the help.
jcow is offline   Reply With Quote
Unread 06-26-2010, 08:55 AM   #26
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: 94 club car quit working

they,ll do that ( post coming loose ) double check your white wire isn,t burnt thur anywhere and replace solenoid you,ll be up and running again..................................
shadowman is offline   Reply With Quote
Unread 06-27-2010, 10:47 PM   #27
Not Yet Wild
 
coolbob's Avatar
Club Car
 
Join Date: Apr 2009
Location: lanaudiere (quebec)
Posts: 51
Default Re: 94 club car quit working

Quote:
Originally Posted by shadowman View Post
it could be a solenoid going bad so if it quits again try jumping it......................
how do you jump the solenoid ??
coolbob is offline   Reply With Quote
Unread 06-28-2010, 03:55 PM   #28
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: 94 club car quit working

with a peice of 6 gage cable you touch one end to each of the large post on solenoid.......make sure cart is jacked up in rear and off.......after you have jumper in place turn key on put in gear and hit pedal if solenoid is bad the cart will run when you do this and quit running without the jumper so you replace with a good solenod....................................
shadowman is offline   Reply With Quote
Unread 02-26-2011, 08:31 PM   #29
Not Yet Wild
 
Join Date: May 2010
Posts: 7
Default Re: 94 club car quit working

Thanks for this thread!

My Ds 94 - 36V with Controller stopped running. The trick was to jack up the cart, then jumper the two poles on the solenoid. Then hit the pedal. Yes! The wheels were turning!

Now I have ordered a new solenoid. I'm tempted to go down to NAPA and get one, but they say not too in this forum :)

Thanks guys

edit: I did go down to NAPA and got a solenoid. I just could't wait. The new solenoid arrives in a few business days...The golf cart rolls yet again and my 14 yr old twins will make the golf course unsafe yet again.
Ratatass is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
ds was crashed and quit working Electric Club Car
Buzzer Quit Working Electric Club Car
Brake lights quit working Electric Club Car
my charger quit working Electric EZGO
lights quit working Electric EZGO


All times are GMT -5. The time now is 07:43 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.