lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 07-02-2010, 05:29 PM   #1
Not Yet Wild
 
Join Date: Jul 2010
Posts: 26
Default 96 cc..no go at times

HAPPY 4TH;
I HAVE A 96 CLUB CAR.IT WAS RUNNING GREAT AND THEN
BECAME INTERMITTENT.BATTERIES ARE INSTALLED 3/09..51.7 VOLTS AT END OF PACK..TRIED TO CHECK SOLENOIDS AND SOME TIMES THEY CLICK
SOMETIMES THEY DON'T. BOTH SOLENOIDS WITH KEY OFF BIG TERMINALS PACK VOLT(51.7) LITTLE TERMINALS ZERO VOLT ..KEY ON... ALL TERMINALS READ BATTERY VOLT ..I DON'T HAVE ANY IDEA WHAT IS WRONG...I AM A RETIRED AUTO TECH. BUT HAVE NO CLUE AS TO WHAT THE PARTS ARE CALLED AND HAVE NO MANUAL. ANY SUGGESTIONS....THANK YOU.
OLDESTCOWBOY is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 07-02-2010, 07:05 PM   #2
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: 96 cc..no go at times

you could have a solenoid going bad...next time it quits try tapping it to see if it will run if so replace it.........its the one on the outer frame rail the other is for the reagan braking system.......if you do replace solenoid make sure you kill pack power and use a HD white rodgers 48 volt solenoid..........oh yea happy 4th.........................
shadowman is offline   Reply With Quote
Unread 07-03-2010, 03:19 PM   #3
Not Yet Wild
 
Join Date: Jul 2010
Posts: 26
Default Re: 96 cc..no go at times

JUST TO LET EVERYONE NO WHAT THE PROBLEM WAS.......THE 3 PRONG CONNECTOR FROM THE POT. ON BOTTOM OF ACCEL.PEDAL...WHEN I TOOK THE CONNECTOR APART THERE WAS A LITTLE CORROSION..RATHER THEN CLEAN CONNECTORS I CUT IT OUT AND SOLDERED WIRES TOGETHER...
(3 WIRES) THAT TOOK CARE OF PROBLEM..RUNS GREAT NOW...tHANKS TO EVERYONE WHO HELPED...................BOB
OLDESTCOWBOY is offline   Reply With Quote
Unread 07-03-2010, 05:29 PM   #4
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: 96 cc..no go at times

thanks for letting us know.............................................. .....
shadowman is offline   Reply With Quote
Unread 07-06-2010, 07:14 PM   #5
Not Yet Wild
 
Mongrell's Avatar
Club Car
 
Join Date: Jul 2010
Location: Michigan
Posts: 2
Default Re: 96 cc..no go at times

Wow looking here for help to fix my fathers Cart. I think you just answed my question of what was goofy on it.
Woot off to Dad's place to fix his fav toy to bebop around the land with.
Thanks again
Mongrell is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
HA9144 Sometimes goes other times not Electric Club Car
Battery Run Times with mods Electric Club Car


All times are GMT -5. The time now is 12:00 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.