lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 07-10-2010, 12:20 AM   #1
Not Yet Wild
Club Car
 
Join Date: Jul 2008
Location: Southwest Ohio
Posts: 34
Default Body change = no charge

I changed out the body on my 06 ds iq regen with 4 12 volt batterys. After all was done I plugged in charger and nothing, tried different charger same results. Found small 3/8 amp fuse in yellow holder blown. I had disconnected the red battery lead before starting. Don't know if fuse was blown at this time. I have checked as much wiring as I can think of all appears to be where it should be. I did not have run/tow switch in tow while disconnecting or connecting.
Any thoughts on what may have happened?
crunch1 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 07-10-2010, 09:12 AM   #2
Not Yet Wild
Club Car
 
Join Date: Jul 2008
Location: Southwest Ohio
Posts: 34
Default Re: Body change = no charge

I could really use some help here guys, any ideas on whats up ? Cart appears to run OK . Guess I wil replace fuse and try again.
crunch1 is offline   Reply With Quote
Unread 07-10-2010, 11:44 AM   #3
Gone Wild
 
rabbitreborn's Avatar
E-Z-GO
 
Join Date: Jun 2010
Location: Central Florida
Posts: 2,704
Default Re: Body change = no charge

replacing the fuse would be the FIRST step. Noone will be able to assist until that fuse is replaced. If you are still having issue then, let us know.
rabbitreborn is offline   Reply With Quote
Unread 07-10-2010, 01:01 PM   #4
Not Yet Wild
Club Car
 
Join Date: Jul 2008
Location: Southwest Ohio
Posts: 34
Default Re: Body change = no charge

Should not let minor things shake me. Replaced fuse and all is good.
Don't know if I shorted something,[ most likely self inflicted ] or if it was that way @ delivery.
Thanks all for your time.
crunch1 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
To charge or not to charge.... wtf is the question? Gas Club Car
name change Gas Yamaha
green body or camo dipped body Electric Club Car
98 ezgo charge meter not showing actual charge Electric EZGO


All times are GMT -5. The time now is 12:23 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.