lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 07-10-2010, 12:22 AM   #1
Not Yet Wild
Club Car
 
Join Date: Jul 2008
Location: Southwest Ohio
Posts: 34
Default Body change = no charge

I changed out the body on my 06 ds with 4 12 vot batterys. After all was done I plugged in charger and nothing, tried different charger same results. Found small 3/8 amp fuse in yellow holder blown. I had disconnected the red battery lead before starting. Don't know if fuse was blown at this time. I have checked as much wiring as I can think of all appears to be where it should be. I did not have run/tow switch in tow while disconnecting or connecting.
Any thoughts on what may have happened?
crunch1 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 07-10-2010, 09:10 AM   #2
Not Yet Wild
Club Car
 
Join Date: Jul 2008
Location: Southwest Ohio
Posts: 34
Default Re: Body change = no charge

Could really use some advice here guys. Cart appears to run ok .
crunch1 is offline   Reply With Quote
Unread 07-10-2010, 09:10 AM   #3
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,043
Default Re: Body change = no charge

Replace that 3/8ths amp fuse with an identical fuse, it protects the OBC. No telling what happened, a 3/8th fuse is easy to melt.
The charger should work once it is replaced.
scottyb is online now   Reply With Quote
Unread 07-10-2010, 09:38 AM   #4
Gone Wild
 
OLD MEC's Avatar
Club Car
 
Join Date: Mar 2009
Location: South Texas
Posts: 2,391
Default Re: Body change = no charge

Question--did you run ground cable through OBC, if not OBC can't see batterys and wont turn charger on. Also did you reconnect plus wire from charger receptical back onto #1 battery plus or solenoid? JUST SOME THOUGHTS?
OLD MEC is offline   Reply With Quote
Unread 07-11-2010, 11:13 PM   #5
Not Yet Wild
Club Car
 
Join Date: Jul 2008
Location: Southwest Ohio
Posts: 34
Default Re: Body change = no charge

Replaced bad fuse and all is well. I most likley shorted the charge recepticle or ? in the process, before removing positive lead.
Thanks for the responce, must learn to keep fat fingers from doing bad things
crunch1 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
To charge or not to charge.... wtf is the question? Gas Club Car
Body change = no charge Electric Club Car
green body or camo dipped body Electric Club Car
36V TO 48V TO 72v WHAT DO I CHANGE????? Electric EZGO
98 ezgo charge meter not showing actual charge Electric EZGO


All times are GMT -5. The time now is 10:17 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.