lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 07-12-2010, 02:01 PM   #1
Not Yet Wild
 
Join Date: Jul 2010
Posts: 5
Default 92 cc charging problems

I have a 1992 Club car 36 volts. the insulstion is melted off the cable going to one of the resistor. When you plug the charger in it go's to 20 and never drops. All the batterys are wired in the right order and are brand new last week checked out good. I thought that I had a bad battery so I went on and got new ones. When you depress the go pedal it is hard to push like it is stuck could there be a prblem with the vglide just replaced it last fall. Thank you
springfieldrace1 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 07-12-2010, 02:47 PM   #2
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,088
Default Re: 92 cc charging problems

Welcome to BGW! What is the battery pack voltage reading at the batteries and again what is the battery pack voltage reading at the charger receptacle ?
scottyb is offline   Reply With Quote
Unread 07-12-2010, 03:30 PM   #3
Not Yet Wild
 
Join Date: Jul 2010
Posts: 5
Default Re: 92 cc charging problems

when the batterys where new it was 42 now it onley gets to 36 have not checked it at the charge. I used a buddy of mine charger it did the same thing went to 20 and never dropped below that
springfieldrace1 is offline   Reply With Quote
Unread 07-12-2010, 04:23 PM   #4
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: 92 cc charging problems

1st get that cable replaced or repaired that could be the problem or not but it needs to be fixed..................even though they are new batts, check voltage in each one and load test................ its quite possible you have more than one problem................................
shadowman is offline   Reply With Quote
Unread 07-12-2010, 07:17 PM   #5
Not Yet Wild
 
Join Date: Jun 2010
Posts: 30
Default Re: 92 cc charging problems

Agree with shadowman, replace that cable and check all the cables, especially around vglide. Sounds like something could be shorted out. The charger doesn't know if it is sending 20 amps through the batteries or through the something else.
pitstop racing is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Charging problems Electric EZGO
Charging Problems Electric Club Car
charging problems Electric Club Car
Ds Charging Problems Electric Club Car
charging problems Electric Club Car


All times are GMT -5. The time now is 02:49 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.