lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars

Post New Thread  Reply
Thread Tools Display Modes
Unread 07-22-2010, 09:59 AM   #1
Not Yet Wild
Join Date: Jul 2010
Posts: 18
Default 1990 club cart wont go

I have a 1990 club car 36 volt it was running fine for about 30 minutes wide open then it gets really slow we have tested batteries a couple of times even took them to napa had them test them all checks out good. I put it on charge it charges for about 3 hours then turns off and runs good for about 30 to 45 minutes. So last night I charged it back up turn the key and press the gas pedal it wouldnt go. The pedal just made like a grinding noise. We looked inside v-glide but can't figure it out. We really don't know what were looking at so any advise would be appreciated.
doupaint2 is offline   Reply With Quote
Alt Today

Golf car forum Sponsored Links

This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
Unread 07-22-2010, 10:29 AM   #2
The Last Moja Morani
shadowman's Avatar
Club Car
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: 1990 club cart wont go

did they load test the batteries and check cells with hydrometer? if not do both of those.........what kind of shape are your cables in? if your not sure replace for the V-glide disconnect main power and take that front battery out so you can see things........with cover off V-glide slowly press your pedal to see how smooth things are there is a movable wiper arm mounted on a plastic bracket and as you push that wiper arm slides across the copper contacts you want all of that in good clean shape, does the solenoid click when you step on pedal? jack the rear of the cart up and with a 6 gage jumper cable jump the large post on solenoid and see if cart will run.......if so replace solenoid.........but start by being certain your batts are good and load test good and your cables are good and connections clean on cables and batt. terminals............also make sure water level is good if you need to add use distilled water only if any are dry we need to know how dry..................................start with this stuff and post what you find.........................................
shadowman is offline   Reply With Quote
Unread 07-23-2010, 08:02 PM   #3
Not Yet Wild
Join Date: Jul 2010
Posts: 18
Default Re: 1990 club cart wont go

i checked the batteries with a load tester and they tested good. we then tested each cell with one at a time. every cell, on 2 batteries were low, 2 batteries had 1 low cell in each, 2 batteries were good. what should we do at this point?
doupaint2 is offline   Reply With Quote
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car

Thread Tools
Display Modes

Similar Threads
Thread Forum
Service Manual for 1993 P4G cart Gas Columbia ParCar
cart wont run sometimes Gas Club Car
1993 Club Cart Brake adjustment Electric Club Car
1993 Melex Cart differential problem Melex
1993 gas yamaha golf cart Gas Yamaha

All times are GMT -5. The time now is 10:34 AM.

Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.