lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 07-31-2010, 11:26 AM   #1
Not Yet Wild
 
Join Date: Jul 2010
Posts: 3
Default 1997 Club Car - lost power while driving

I have a 1997 Electric Club Car which has been running perfectly for 10 years. Recently it lost power while driving. Checked batteries which seem ok with rough measurement of about 38 volts+-. There does not seem to be any voltage to the rheostat switch. Although I can't see how it's designed, it seems like it might be due to the forward/reverse switch??? Any thoughts on how to test it further to know if it is the forward/reverse switch. Are there other tests that I can do to isolate the problem?
James Serum is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
WHY??? Motor got hot and lost most power Electric EZGO
Golf Cart Lost Power Electric EZGO
Lost power Electric Club Car
Lost Power Electric EZGO
Club car lost power on impact to differential Electric Club Car


All times are GMT -5. The time now is 06:50 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.