lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 08-03-2010, 11:13 AM   #1
Not Yet Wild
Yamaha
 
Join Date: Jun 2008
Location: Lebanon, NH
Posts: 7
Default Acellerator problems

I am constantly working on golf carts at our campground cleaning battery terminals etc but I have come across a problem that I have not seen before.

I have recently cleaned the battery terminals and made a new cable for a burnt one and filled all the water. The cart was on the charger for the night and the next day it seem to back up fine, but when you want to go forward, if you press the acellerator lightly, it starts slow, If you press the acellerator to the floor, it bucks the cart and doesn't really go anywhere. Forget going up hills, it isn't going to happen.

Is there a riostat on the gas pedal fore the Club Car eleltric carts?

Any one seen this before? Thank you for your help in advance.
the-mace is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 08-03-2010, 11:22 AM   #2
let it SNOW
 
redriderno22's Avatar
Club Car
 
Join Date: Apr 2009
Location: Marengo OHIO
Posts: 870
Default Re: Acellerator problems

what year and voltage is it?
redriderno22 is offline   Reply With Quote
Unread 08-03-2010, 05:37 PM   #3
Gone Wild
 
OLD MEC's Avatar
Club Car
 
Join Date: Mar 2009
Location: South Texas
Posts: 2,391
Default Re: Acellerator problems

Please if you want help give make, model year and voltage of cart to speed up help.
OLD MEC is offline   Reply With Quote
Unread 08-03-2010, 08:51 PM   #4
Gone Wild
E-Z-GO
 
Join Date: Mar 2010
Location: Mountaindale, Oregon
Posts: 303
Default Re: Acellerator problems

Quote:
Originally Posted by the-mace View Post
I am constantly working on golf carts at our campground cleaning battery terminals etc but I have come across a problem that I have not seen before.

I have recently cleaned the battery terminals and made a new cable for a burnt one and filled all the water. The cart was on the charger for the night and the next day it seem to back up fine, but when you want to go forward, if you press the acellerator lightly, it starts slow, If you press the acellerator to the floor, it bucks the cart and doesn't really go anywhere. Forget going up hills, it isn't going to happen.

Is there a riostat on the gas pedal fore the Club Car eleltric carts?

Any one seen this before? Thank you for your help in advance.
Was the cart operational prior to your cleaning/adding new cable? Check for proper connections to/between the batteries. What is the total pack voltage?
e-z-go1988 is offline   Reply With Quote
Unread 08-03-2010, 09:44 PM   #5
Not Yet Wild
Yamaha
 
Join Date: Jun 2008
Location: Lebanon, NH
Posts: 7
Default Re: Acellerator problems

The cart is a 36 volt but I don't know what year it is. The cart would not go anywhere with the batteries as bad as they were. I don't think the owner ever noticed the jerking motion before.

Thank you for your help.
the-mace is offline   Reply With Quote
Unread 08-04-2010, 12:48 AM   #6
Gone Wild
 
rabbitreborn's Avatar
E-Z-GO
 
Join Date: Jun 2010
Location: Central Florida
Posts: 2,704
Default Re: Acellerator problems

doesn't matter what year it is at this point.....

The problem is caused by either a faulty wire or a bad battery on the Passenger side of the cart. Depending on which battery they have the reverse power coming from (factory setup was to connect reverse to the D/S middle battery but alot of people want faster reverse and connect it to the P/S middle battery), it could be 1 of 3 batteries causing the problem. check the 2 on the passenger side first, if both of those are testing fine, then test the middle battery on the Passenger side. One of those 3 (or the wiring between them) is bad.
rabbitreborn is offline   Reply With Quote
Unread 08-09-2010, 01:30 PM   #7
Not Yet Wild
Yamaha
 
Join Date: Jun 2008
Location: Lebanon, NH
Posts: 7
Default Re: Acellerator problems

Thank you for your help. I'll check it out.
the-mace is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
possble battery problems or possible charger problems? Extreme DC!
6 passanger trouble shooting. Controller problems/gas/or brake problems. Electric EZGO
The New Guy With Problems Gas Club Car
F&R problems Electric EZGO


All times are GMT -5. The time now is 05:38 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.