lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 08-04-2010, 09:59 PM   #1
Not Yet Wild
 
Join Date: Jun 2010
Posts: 30
Default 94cc- after 3 solenoids, found the problem. thanks

By accident tonight, I found why I was smoking solenoids. I had replaced the switches/resistor/diode and solenoid for 3rd time. Then I noticed that when I turned on the key, there was a click in the controller which sould only occur with key and gas pedal pushed. It turned out to be that the gas pedal was not returning completely. This left the control circuit open when the key was on. I am guessing that running the control circuit overnight would over heat the solenoid, if you left the key on, as I had thought I'd done....live/learn/pass it on..
pitstop racing is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 08-04-2010, 10:59 PM   #2
Gone Wild
 
rabbitreborn's Avatar
E-Z-GO
 
Join Date: Jun 2010
Location: Central Florida
Posts: 2,704
Default Re: 94cc- after 3 solenoids, found the problem. thanks

wow, I had never even thought about that happening.... I've had it happen to me before, but the thought never crossed my mind when we were talking about your cart.

Glad to know you finally figured out the problem!
rabbitreborn is offline   Reply With Quote
Unread 08-05-2010, 10:54 AM   #3
Gone Wild
 
OLD MEC's Avatar
Club Car
 
Join Date: Mar 2009
Location: South Texas
Posts: 2,391
Default Re: 94cc- after 3 solenoids, found the problem. thanks

Great fix this shows that you are on the ball. This is a lesson for all of us to check and double check and dont assume anything?
OLD MEC is offline   Reply With Quote
Unread 08-05-2010, 11:10 AM   #4
Moderator
 
rib33024's Avatar
E-Z-GO
 
Join Date: Apr 2009
Location: FT Lauderdale FL.
Posts: 13,160
Default Re: 94cc- after 3 solenoids, found the problem. thanks

Quote:
Originally Posted by OLD MEC View Post
Great fix this shows that you are on the ball. This is a lesson for all of us to check and double check and dont assume anything?

Yes thats some good info--
rib33024 is offline   Reply With Quote
Unread 08-05-2010, 09:49 PM   #5
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: 94cc- after 3 solenoids, found the problem. thanks

i agree thanks for letting us know..............................
shadowman is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
OK I found out the Problem- 2/3s of the family does not believe in automatice charge Electric EZGO
are ford solenoids and cc solenoids interchangeable Gas Club Car
ok, found a problem Gas Yamaha
I have not found problem yet, but... Gas Yamaha


All times are GMT -5. The time now is 04:53 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.