lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 08-09-2010, 02:15 PM   #1
Not Yet Wild
Club Car
 
Join Date: Oct 2008
Location: Gonzales,Texas
Posts: 55
Default Shudder on take off

Got my Logisystem 700 amp controller couple weeks ago and installed it along with high speed motor from CartZone previously installed.All I can say is hang on!Same speed as before "27mph" but will spin tires in loose gravel or slick concrete and gets to the speed in half the time!
Quiestion is that at a sloww take off or trying to maintane a slow speed I get a bad shudder like power going in in out If you just floor it no problems but if you feather it kinda goes ;start,clunk,start,clunk, then smoothes out. And when wanting to go like 2 or 3 mph it constantly clunks back and forth?
Any Takers or help greatly appriciated!
TIA
abtgtown is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 08-09-2010, 03:18 PM   #2
Gone Wild
 
cheapjeep2's Avatar
Club Car
 
Join Date: Nov 2008
Location: Peachtree City, Georgia
Posts: 1,529
Default Re: Shudder on take off

Quote:
Originally Posted by abtgtown View Post
Got my Logisystem 700 amp controller couple weeks ago and installed it along with high speed motor from CartZone previously installed.All I can say is hang on!Same speed as before "27mph" but will spin tires in loose gravel or slick concrete and gets to the speed in half the time!
Quiestion is that at a sloww take off or trying to maintane a slow speed I get a bad shudder like power going in in out If you just floor it no problems but if you feather it kinda goes ;start,clunk,start,clunk, then smoothes out. And when wanting to go like 2 or 3 mph it constantly clunks back and forth?
Any Takers or help greatly appriciated!
TIA
What year is the cart? Sounds like the throttle input, common problem for MCOR units, if yours has one.
cheapjeep2 is offline   Reply With Quote
Unread 08-09-2010, 03:23 PM   #3
Not Yet Wild
Club Car
 
Join Date: Oct 2008
Location: Gonzales,Texas
Posts: 55
Default Re: Shudder on take off

2001 Club Car Series 48volt
abtgtown is offline   Reply With Quote
Unread 08-09-2010, 03:28 PM   #4
Gone Wild
 
cheapjeep2's Avatar
Club Car
 
Join Date: Nov 2008
Location: Peachtree City, Georgia
Posts: 1,529
Default Re: Shudder on take off

Quote:
Originally Posted by abtgtown View Post
2001 Club Car Series 48volt

Does it have the MCOR unit? These are a black box on the passenger side frame rail right under the passenger side foot area. Check and see if you have one of these. Looks like this MCOR

If so, replace it as that is most likely your problem.
cheapjeep2 is offline   Reply With Quote
Unread 08-09-2010, 03:37 PM   #5
Not Yet Wild
Club Car
 
Join Date: Oct 2008
Location: Gonzales,Texas
Posts: 55
Default Re: Shudder on take off

will check this afternoon and get back with ya!
thanks
abtgtown is offline   Reply With Quote
Unread 08-12-2010, 07:29 PM   #6
Not Yet Wild
Club Car
 
Join Date: Oct 2008
Location: Gonzales,Texas
Posts: 55
Default Re: Shudder on take off

Finally checked cart and yes it has a MCOR! We sure that is what I need before I spend another 100 to 150 dollars?lol May be a silly question but why did I never notice the shudder with old controller!?
abtgtown is offline   Reply With Quote
Unread 08-12-2010, 07:49 PM   #7
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: Shudder on take off

i,m gussing your pulling more amps with the 700 amp controller and it could be an indication of a battery problem, load test your batts since its only doing it when taking off........i,m guessing and i,ll be corrected if i,m wrong and someone else may know more about it hopefully they,ll chime in......................
shadowman is offline   Reply With Quote
Unread 08-13-2010, 09:53 AM   #8
Not Yet Wild
Club Car
 
Join Date: Oct 2008
Location: Gonzales,Texas
Posts: 55
Default Re: Shudder on take off

Load tested batteries everything fine. Batteries are less than a year old, Trojan 875's. Don't think they are an issue?
abtgtown is offline   Reply With Quote
Unread 08-13-2010, 09:59 AM   #9
Gone Wild
 
cheapjeep2's Avatar
Club Car
 
Join Date: Nov 2008
Location: Peachtree City, Georgia
Posts: 1,529
Default Re: Shudder on take off

They go bad, plain and simple, I have my stock controller, upgraded to a 500amp, ran fine for a bit and then a few months later MCOR started having problems. I simply replaced it and never looked back.
cheapjeep2 is offline   Reply With Quote
Unread 08-13-2010, 10:13 AM   #10
tej
Not Yet Wild
 
tej's Avatar
 
Join Date: Jul 2008
Location: Texas
Posts: 12
Default Re: Shudder on take off

I had the same problem with an Alltrax controller. I was able to program out the shudder by changing the ramp up and ramp down rates. Also, mine works never did shudder with the standard controller. I put the standard back on just to make sure.
tej is offline   Reply With Quote
Reply

Tags
700 amp logisystems w/hsm
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Lack of Forward Power - Small Shudder Electric EZGO
Slow start shudder Electric Club Car


All times are GMT -5. The time now is 03:59 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.