lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 08-15-2010, 09:20 AM   #1
Not Yet Wild
 
Join Date: Aug 2010
Posts: 3
Default Club Car will not run after rebuild

I took apart my late 80's club car to repair damage. After putting it back together it will not run. The lights work. The back up alarm will not sound and the charger will not charge. No power when I press the gas. I started to trouble shoot the system. All drwg. have two wire key switch mine has three. Where do I start?
D Craig is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 08-15-2010, 09:34 AM   #2
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,093
Default Re: Club Car will not run after rebuild

Is it a resistor coil cart? Did you check the micro switches for continuity?
scottyb is offline   Reply With Quote
Unread 08-15-2010, 10:08 AM   #3
Not Yet Wild
 
Join Date: Aug 2010
Posts: 3
Default Re: Club Car will not run after rebuild

It has a resistor assembly, a key switch, a solenoid and a forward, reverse buzzer and r/f switch. My key switch has one wire that goes to the positive side of the #3 battery and two other wires. It is almost like the key switch is not working. I did not have a meter last night to t shoot the unit. So today at working I was looking for a drawing to work with. Every one showes a two wire switch. Also, I did not disconnect any wires during the rebuild except the batteries. Before the rebuild the charger worked ( not now) and the back up buzzer worked if the unit was put in reverse ( not now)
D Craig is offline   Reply With Quote
Unread 08-15-2010, 10:13 AM   #4
Not Yet Wild
 
Join Date: Aug 2010
Posts: 3
Default Re: Club Car will not run after rebuild

It appears to match a drqwing posted as a 88-03 electric club car wiring diagram with v-glide.
D Craig is offline   Reply With Quote
Unread 08-15-2010, 11:21 AM   #5
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,093
Default Re: Club Car will not run after rebuild

It appears you have the key switch connected to 18v is that correct? Check that 88-03 resistor coil cart diagram in the stickies... that might be your problem since you didn't undo anything else?
scottyb is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
89 Club Car Top End Rebuild Gas Club Car
Club car rebuild start Lifted Golf Carts
Club Car IQ Rebuild ~ Courtesy of IKE Electric Club Car
91 club car, new rebuild, low compression Gas Club Car
Club Car Rebuild Gas Club Car


All times are GMT -5. The time now is 12:17 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.