lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 08-17-2010, 10:51 AM   #1
Not Yet Wild
 
Join Date: Apr 2010
Posts: 11
Default '81 Club Car DS wont Run

I have a 1981 Club car DS that wont run. I have tested the batteries with a hydrometer and they appear to all be fine (they are Trojan-105's and only two years old) I can depress the pedal gradually and I hear all 5 solenoids "click". Any idea what else I could check? Thanks!
rfurnell93 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 08-17-2010, 11:18 AM   #2
Gone Wild
 
OLD MEC's Avatar
Club Car
 
Join Date: Mar 2009
Location: South Texas
Posts: 2,391
Default Re: '81 Club Car DS wont Run

"Tested batteys with hydrometer and appear fine"?? What type of hydrometer did you use, a single float temperature correcting unit or one of the ANTIFREEZE MULTI FLOAT UNITS? What were your hydrometer readings and were they taken at least ONE HOUR after charging to allow for equilization? Start with batterys and then after confirming condition you can start to trouble shoot your problem. The older models like yours have lots of problems with solenoids and resistor coils cracking. Even though the solenoids click doesnt mean that they will make internal contact, but first lets see about batterys and connections. Record each cells readings and compare with STICKIES ABOVE titled "STATE OF CHARGE READINGS"
OLD MEC is offline   Reply With Quote
Unread 08-17-2010, 11:23 AM   #3
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,050
Default Re: '81 Club Car DS wont Run

Just because a solenoid makes a click sound doesn't mean it is working properly. Test the Master solenoid, closest to the driver's side to see if in fact power is passing thru it when it clicks.
scottyb is offline   Reply With Quote
Unread 08-17-2010, 11:37 AM   #4
Not Yet Wild
 
Join Date: Apr 2010
Posts: 11
Default Re: '81 Club Car DS wont Run

Old Mec: I have a temperature compensating hydrometer. Is that sufficient?


Scotty B: How do I test the master solenoid?
rfurnell93 is offline   Reply With Quote
Unread 08-17-2010, 01:38 PM   #5
Gone Wild
 
OLD MEC's Avatar
Club Car
 
Join Date: Mar 2009
Location: South Texas
Posts: 2,391
Default Re: '81 Club Car DS wont Run

If its a single float unit it will work fine, but remenber to wait at least one hour after being on charger.
OLD MEC is offline   Reply With Quote
Unread 08-18-2010, 10:22 AM   #6
Not Yet Wild
 
Join Date: Apr 2010
Posts: 11
Default Re: '81 Club Car DS wont Run

Ok, the batteries are good. I jumped the solenoid and the cart will run. Does that mean I have one or more bad solenoids?
rfurnell93 is offline   Reply With Quote
Unread 08-18-2010, 10:38 AM   #7
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,050
Default Re: '81 Club Car DS wont Run

Can I assume you jumped the Master solenoid?
It tells you 1 of 2 things; the solenoid is bad or the solenoid activation circuit is bad.

The solenoid is activated when pos and neg 36v is applied to the 2 small terminals on the solenoid
scottyb is offline   Reply With Quote
Unread 08-18-2010, 11:19 AM   #8
Not Yet Wild
 
Join Date: Apr 2010
Posts: 11
Default Re: '81 Club Car DS wont Run

Yes, I did jump the master solenoid. Do yo mean the master solenoid is bad? How would I know which one? Also, is the master solenoid the same as the rest of them? Thanks for your insight.
rfurnell93 is offline   Reply With Quote
Unread 08-18-2010, 11:24 AM   #9
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,050
Default Re: '81 Club Car DS wont Run

If you jumped the master solenoid then that is the one we are talking about ... yes they are all the same 36v solenoids but you do not know if yours IS bad until you check the activation circuit as described.
scottyb is offline   Reply With Quote
Unread 08-18-2010, 12:34 PM   #10
Not Yet Wild
 
Join Date: Apr 2010
Posts: 11
Default Re: '81 Club Car DS wont Run

I apologize if you are having to repeat the same thing, but I just want to be clear. So, can you please describe a little more specifically how I check the activation circuit? Does each solenoid have its own activation circuit?
rfurnell93 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
91 club car wont go Electric Club Car
Club car wont run Electric Club Car
91 club car wont go Electric Club Car
36v club car wont run!! Electric Club Car
club car wont go Electric Club Car


All times are GMT -5. The time now is 07:42 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.