lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 08-19-2010, 11:47 PM   #1
Not Yet Wild
 
Join Date: Aug 2010
Posts: 4
Default millisecond power losses

I have a 1992 electric Club Car. You push the accelerator down and your driving, there is a feeling that the key is being turned off and on, causing a jerky effect. We have changed the solenoid, diode, resister, cleaned all the connections and changed out the micro switches....nothing seems to help. Any suggestions...please...
Doug33 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 08-19-2010, 11:52 PM   #2
let it SNOW
 
redriderno22's Avatar
Club Car
 
Join Date: Apr 2009
Location: Marengo OHIO
Posts: 870
Default Re: millisecond power losses

have you looked at the motor?

sounds like it could be a pitted comm, or a worn brush
redriderno22 is offline   Reply With Quote
Unread 08-20-2010, 10:02 AM   #3
Gone Wild
 
OLD MEC's Avatar
Club Car
 
Join Date: Mar 2009
Location: South Texas
Posts: 2,391
Default Re: millisecond power losses

Have you checked your batterys for condition as often a bad battery will cause the problem you have? Get a single float hydrometer with temperature correction ( NOT A ANTIFREEZE MULTI BALL UNIT ) and check each cell and record ( note this must be done after wating one hour after charging or if distilled water added after charging and again waiting one hour ). Refer to STICKIES ABOVE under "STATE OF CHARGE READINGS"
If you have a digital volt meter check voltage on each battery and record and then check full pack voltage and refer back to same STICKIES file.
OLD MEC is offline   Reply With Quote
Unread 08-23-2010, 07:57 PM   #4
Not Yet Wild
 
Join Date: Aug 2010
Posts: 4
Default Re: millisecond power losses

thanks for the info - will check on both of these suggestions....but Sticky File?? sorry, don't see where that is at all.....
Doug33 is offline   Reply With Quote
Unread 08-24-2010, 12:25 AM   #5
Not Yet Wild
 
Join Date: Aug 2010
Posts: 4
Default Re: millisecond power losses

Again, thanks for the info... got the "Stickies" now...thanks.
Doug33 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Power Wise Charger worked after board replaced now back to no power Electric EZGO
How to get more power out of my G9 Gas Yamaha
Power in Reverse/Little Power in Forward Gas Harley Davidson
no power Electric EZGO


All times are GMT -5. The time now is 04:56 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.