lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 08-29-2010, 05:15 PM   #21
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: Charger not coming on

have you tried the charger on another cart?...................................
shadowman is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 08-29-2010, 05:49 PM   #22
Gone Wild
 
SaltLifeCC's Avatar
 
Join Date: Jun 2010
Posts: 729
Default Re: Charger not coming on

I don't have access to another cart to try charger on.
SaltLifeCC is offline   Reply With Quote
Unread 08-29-2010, 05:59 PM   #23
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: Charger not coming on

can you take your charger to try on another cart? all i want to do is eliminate one or the other............................................. .......
shadowman is offline   Reply With Quote
Unread 08-29-2010, 06:06 PM   #24
Gone Wild
 
Colbyntx's Avatar
Club Car
 
Join Date: Jun 2010
Location: East Texas
Posts: 602
Default Re: Charger not coming on

Red, there is a sticky on the top of this forum with the book on this charger. Down load it and print it. It is about 158 pages but it will walk you through trouble shooting and help you fix the problem and ID the parts. It is written so even I can understand! The part that has 15A on it should have a button for reset. It comes out to the inside of the charger but you have to take off the cover.
Colbyntx is offline   Reply With Quote
Unread 08-30-2010, 08:38 AM   #25
Gone Wild
 
SaltLifeCC's Avatar
 
Join Date: Jun 2010
Posts: 729
Default Re: Charger not coming on

Quick question - there are 3 pins on the connector that plugs into the cart. 2 at the bottom of the plug and one at the top. I never paid any attention to it until now but are all 3 supposed to be sticking out the same distance or is it normal for the single pin at the top to be shorter? It doesn't appear to move in or out very easily but I want to make sure my problem is not as simple as a pin that has gotten pushed in too far and my third pin sticks out about half as far as the other 2.
SaltLifeCC is offline   Reply With Quote
Unread 08-30-2010, 10:34 AM   #26
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 8,030
Default Re: Charger not coming on

The single pin is shorter. That is normal
TahoeDawgZ71 is online now   Reply With Quote
Unread 08-30-2010, 11:03 AM   #27
Gone Wild
 
SaltLifeCC's Avatar
 
Join Date: Jun 2010
Posts: 729
Default Re: Charger not coming on

Thanks TD. So, I'm trying to get going here. I now own a multi-meter and a hydrometer and have downloaded the charger manual.

Starting with the batteries first with the cart sitting still in tow mode:

Battery 1 - 11.86v
Battery 2 - 11.85v
Battery 3 - 11.75v (this is the one I charged individually yesterday that was showing 8v)
Battery 4 - 11.86v
Battery Pack - 47.2v

Does the above indicate anything other than it probably is time to charge up? That's what I'm trying to do but still can't get charger to activate.

I'm about to start troubleshooting the charger itself but I honestly don't know where to start first. Is there anything on the cart itself that could be reset? The OBC maybe?
SaltLifeCC is offline   Reply With Quote
Unread 08-30-2010, 11:55 AM   #28
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,093
Default Re: Charger not coming on

That is enough voltage to start the charger. Does the charger have a fuse and/or circuit breaker on the face?
scottyb is offline   Reply With Quote
Unread 08-30-2010, 12:26 PM   #29
Gone Wild
 
SaltLifeCC's Avatar
 
Join Date: Jun 2010
Posts: 729
Default Re: Charger not coming on

It doesn't have a fuse on the face - it has a 15a breaker that doesn't seem to be tripped. I opened the charger cover a bit and the fuse I see in there appears to be good and I was able to do the DC continuity test at the charger plug that was in the manual. I'm not a whiz with a multimeter but the manual said to look for approx 878mV when the black probe is touching the positive pin and the red probe is touching the negative. I did get a reading when I did that but it was more like 944-945, not 878 but nothing indicated mV or any other unit of measure.

When I set my mm at 200ohms and put a probe on each terminal on either side of the fuse, I get a reading of 0.2. Have no idea what I'm supposed to see other than confirm continuity.
SaltLifeCC is offline   Reply With Quote
Unread 08-30-2010, 12:48 PM   #30
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 8,030
Default Re: Charger not coming on

PM sent
TahoeDawgZ71 is online now   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Parts are coming Members Rides
Gas coming out exhaust Gas Yamaha


All times are GMT -5. The time now is 02:15 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.