lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 09-11-2010, 08:13 PM   #1
Not Yet Wild
 
Join Date: Sep 2010
Posts: 1
Default 07 Precedent Speed and Hill Problems

I have an 07 Precedent that I bought with another sister cart (one serial number apart from same location). I modified both carts the same with lift kits and rear seats. The problem I have is with the second cart. I noticed that when I would go down steep hills with the first cart (which I have now sold) that the motor held back the cart and would keep the cart speed down. The second cart does not do this and It seems to be a little slower on the top end speed. I also have a problem with the cart occasionally jerking or stopping on hills. I have checked the batteries by load testing them. They are all good. If I pump the accelerator peddle on the hills it seems to eventually go without problems. Do I have one problem or two?
wesleyt1 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 09-11-2010, 10:19 PM   #2
Gone Wild
 
golfcarfixer's Avatar
Club Car
 
Join Date: Sep 2009
Location: DELAWARE
Posts: 2,656
Default Re: 07 Precedent Speed and Hill Problems

Sounds to me like you need to check the batteries with a hydrometer,The load test shows good but thats not always the case.
golfcarfixer is offline   Reply With Quote
Unread 09-11-2010, 11:38 PM   #3
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 7,981
Default Re: 07 Precedent Speed and Hill Problems

Sounds to me like the speed sensor isn't working on the 2nd cart. When a speed sensor fails it will no longer limit top speed. It defaults to approximately 8MPH on level ground, but with no sensor it has no way of reading the speed, therefore when you get on an incline going down hill, it will free wheel and has no limit. Check the speed sensor by putting the car in forward, tow switch in "RUN", key on... and pushing the car by hand. It should try to slow itself down with a "Beep beep beep beep" from the reverse buzzer. If you don't get this result, the speed sensor isn't working.
TahoeDawgZ71 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
2001 ezgo gas hill climbing problems/lift kit Gas EZGO
No speed up a hill? Gas Club Car
When at low speed going up hill makes a groan. Gas Yamaha
down hill break and speed code Electric Club Car
Loosing speed drastically up hill Lifted Golf Carts


All times are GMT -5. The time now is 08:26 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.