lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 10-07-2010, 09:02 AM   #1
Getting Wild
 
Join Date: Apr 2010
Posts: 106
Default stereo installed

Bryan's Phone 057.jpg

Bryan's Phone 058.jpg

Bryan's Phone 060.jpg
screamin chicken is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 10-07-2010, 11:17 AM   #2
Maybe This Weekend :)
 
ChevyRacing75's Avatar
Club Car
 
Join Date: May 2009
Location: Lake Norman, NC
Posts: 6,410
Default Re: stereo installed

Looks like some good airspace. Bet it sounds pretty good
ChevyRacing75 is offline   Reply With Quote
Unread 10-07-2010, 11:20 AM   #3
Gone Wild
 
pocket aces's Avatar
Yamaha
 
Join Date: Jan 2010
Location: Tampa, Fl
Posts: 487
Default Re: stereo installed

Looks good.! I have a stereo and 4 speaker that have been sitting in my garage now for 2 months. Have to many projects.
pocket aces is offline   Reply With Quote
Unread 10-07-2010, 12:31 PM   #4
Getting Wild
 
Join Date: Apr 2010
Posts: 106
Default Re: stereo installed

Thanks, it sounds really good, I just installed a 8 in. bazooka tube and I am running it off a alpine 100 watt amp. The pics. are on the other post on the sub....
screamin chicken is offline   Reply With Quote
Unread 10-08-2010, 05:13 PM   #5
Not Yet Wild
 
txfiremedic's Avatar
Club Car
 
Join Date: Aug 2010
Location: W. Texas
Posts: 14
Default Re: stereo installed

SC, are you running this system off 1 battery, the series or an external battery? Is that a homemade box you built for head unit and speakers? Looks good!
txfiremedic is offline   Reply With Quote
Unread 10-09-2010, 02:19 AM   #6
Getting Wild
 
Join Date: Apr 2010
Posts: 106
Default Re: stereo installed

yes I am running my stereo of of the 1st battery, I have it on a toggle switch so when the cart sits the stereo is completely off. I did just install a 8 in. sub with a 100 watt amp and I am also running that off of the same battery with a toggle switch also in case I just want to listen to the 2 front speakers. I did build my own enclosure for my head unit and speakers. I am going to buy another battery and install it in the back for the amp. Thanks.....
screamin chicken is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
EZ GO with dump bed installed Members Rides
Just had a stereo installed...... Electric EZGO
Anyone installed a FE 400 in a DS cart? Gas Club Car
G9 Lift Kit Installed Lifted Golf Carts


All times are GMT -5. The time now is 10:23 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.