lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 10-11-2010, 11:39 AM   #1
Not Yet Wild
 
Join Date: Oct 2010
Posts: 5
Default Club Car issue

My 2000 Club Car just stopped the other day. I usually work on it myself, but just havent had the time. I brought it to the EZ Go dealer and they fixed it?

They changed the microswitch CC, Vglide wiper arm, vglide wiper brush and wiper switch case assembly. When I picked it up it seemed to run fine until I loaded it onto the trailer it didnt have the power to drive up the ramp never happened before, I thought it was because of a low battery charge.

Well I took it home and charged over night next day still same issue loss of power on inclines and reverse is almost at a stand still unless its down hill.

I need some help!
dgbthree is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 10-11-2010, 12:54 PM   #2
??????
 
LostHusker's Avatar
E-Z-GO
 
Join Date: Sep 2009
Location: South TX
Posts: 8,569
Default Re: Club Car issue

Do you have a resistor cart or solid state cart, what voltage?
LostHusker is offline   Reply With Quote
Unread 10-11-2010, 01:41 PM   #3
Not Yet Wild
 
Join Date: Oct 2010
Posts: 5
Default Re: Club Car issue

36 volt resistor
dgbthree is offline   Reply With Quote
Unread 10-11-2010, 01:50 PM   #4
??????
 
LostHusker's Avatar
E-Z-GO
 
Join Date: Sep 2009
Location: South TX
Posts: 8,569
Default Re: Club Car issue

What is the date code on your batteries, do you have a DVOM to get the pack voltage?
LostHusker is offline   Reply With Quote
Unread 10-11-2010, 01:57 PM   #5
Not Yet Wild
 
Join Date: Oct 2010
Posts: 5
Default Re: Club Car issue

The Ez go dealer checked the batteries when I dropped it off and they immediately determined that wasnt the issue before they changed the parts listed above.
dgbthree is offline   Reply With Quote
Unread 10-11-2010, 02:04 PM   #6
??????
 
LostHusker's Avatar
E-Z-GO
 
Join Date: Sep 2009
Location: South TX
Posts: 8,569
Default Re: Club Car issue

Not sure here, as I have the same cart. I would be inclined to take it back to them and tell them it is not running correctly. I would still get an individual reading on each of the batteries, one of the cells might be bad, or a bad battery which in return would suggest loss of power.
LostHusker is offline   Reply With Quote
Unread 10-12-2010, 09:02 AM   #7
Not Yet Wild
 
Join Date: Oct 2010
Posts: 5
Default Re: Club Car issue

I tested each individual battery yesterday and they were all fine.
dgbthree is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Club Car Reverse Issue Electric Club Car
96 Club Car Coil Issue Gas Club Car
99 club car ds 48v power issue Electric Club Car
Charging Issue 99 Club Car DS Electric Club Car
36v 87' club car issue Electric Club Car


All times are GMT -5. The time now is 04:31 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.